Bug 434944 - post scriptlet in tor-lsb is not x86_64 clean
post scriptlet in tor-lsb is not x86_64 clean
Status: CLOSED DUPLICATE of bug 375361
Product: Fedora
Classification: Fedora
Component: tor (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Enrico Scholz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-26 09:04 EST by Sarantis Paskalis
Modified: 2008-02-26 12:24 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-26 12:24:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to fix multilib problem in tor-lsb post scriptlet (479 bytes, patch)
2008-02-26 09:04 EST, Sarantis Paskalis
no flags Details | Diff

  None (edit)
Description Sarantis Paskalis 2008-02-26 09:04:28 EST
Description of problem:
The %post scriptlet in tor-lsb is not x86_64 clean, since it calls
/usr/lib/lsb/install_initd  instead of /usr/lib64/lsb/install_initd.  The
correct way to fix it is to replace /usr/lib with %libdir which expands to
/usr/lib64 on x86_64.

Patch attached.

Version-Release number of selected component (if applicable):
tor-lsb-0.1.2.17-1.fc8


How reproducible:
On install

Steps to Reproduce:
1. sudo yum install tor
...
unning Transaction
  Installing: libevent                     ######################### [1/4] 
  Installing: tor-core                     ######################### [2/4] 
  Installing: tor-lsb                      ######################### [3/4] 
/var/tmp/rpm-tmp.15910: line 1: /usr/lib/lsb/install_initd: No such file or
directory
error: %post(tor-lsb-0.1.2.17-1.fc8.x86_64) scriptlet failed, exit status 127
  Installing: tor                          ######################### [4/4] 

Installed: tor.x86_64 0:0.1.2.17-1.fc8
Dependency Installed: libevent.x86_64 0:1.3b-1.fc7 tor-core.x86_64
0:0.1.2.17-1.fc8 tor-lsb.x86_64 0:0.1.2.17-1.fc8
Complete!


Expected results:


Additional info:
Comment 1 Sarantis Paskalis 2008-02-26 09:04:28 EST
Created attachment 295912 [details]
patch to fix multilib problem in tor-lsb post scriptlet
Comment 2 Enrico Scholz 2008-02-26 12:24:53 EST

*** This bug has been marked as a duplicate of 375361 ***

Note You need to log in before you can comment on or make changes to this bug.