Bug 434961 - New flex 2.5.34 brakes build of perfectly fine flex files
New flex 2.5.34 brakes build of perfectly fine flex files
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: flex (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Petr Machata
Fedora Extras Quality Assurance
:
: 435047 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-26 10:10 EST by Hans de Goede
Modified: 2015-05-04 21:33 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-27 16:23:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hans de Goede 2008-02-26 10:10:50 EST
This new build of flex (which is in the buildroot now):
http://koji.fedoraproject.org/koji/buildinfo?buildID=39849

Brakes the build of lm_sensors, it seems to no longer see lines like this:
 /* foo bar */
As comments, see:
http://koji.fedoraproject.org/koji/getfile?taskID=470882&name=build.log

For the complete task see:
http://koji.fedoraproject.org/koji/taskinfo?taskID=470879
Comment 1 Petr Machata 2008-02-26 10:24:45 EST
Right, I noticed this bug in testsuite, but though it was a last time change in
CVS.  I'll get in touch with upstream to find out if that's a bug or a feature.
Comment 2 Petr Machata 2008-02-26 10:26:41 EST
"last time change" should have been "last minute change"
Comment 3 Hans de Goede 2008-02-26 10:30:40 EST
Hmm,

I for one vote this is a bug, as it breaks compatibility with existing .l files,
I'm pretty sure lm_sensors is not going to be the only package bitten by this. 

And you know what they say about features: if you can't turn it off its not a
feature its a bug, so atleast there should be some cmdline switch to restore the
old behaviour.
Comment 4 Petr Machata 2008-02-26 11:18:41 EST
Agreed.  However it turns out to be more interesting than that: when I
regenerate the flex scanner with old flex, the bug goes away.  I.e., the bug
only presents itself when original, distributed flex.c is used, or when flex.c
is generated with new flex.
Comment 5 Petr Machata 2008-02-27 12:38:46 EST
Upstream has a patch, and managed to make a 2.5.35 in the meantime.  I just did
a rebase, could you try if that fixes the problem for you?
Comment 6 Petr Machata 2008-02-27 12:40:11 EST
*** Bug 435047 has been marked as a duplicate of this bug. ***
Comment 7 Hans de Goede 2008-02-27 16:17:54 EST
(In reply to comment #5)
> Upstream has a patch, and managed to make a 2.5.35 in the meantime.  I just did
> a rebase, could you try if that fixes the problem for you?

I can confirm that this builds fixes things, both locally and in koji:
http://koji.fedoraproject.org/koji/taskinfo?taskID=473322
Comment 8 Petr Machata 2008-02-27 16:23:26 EST
Nice, thanks.

Note You need to log in before you can comment on or make changes to this bug.