Bug 434981 - Wireshark doesn't start - undefined symbol: plugin_list
Wireshark doesn't start - undefined symbol: plugin_list
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: wireshark (Show other bugs)
8
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Radek Vokal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-26 12:45 EST by David Mueller
Modified: 2008-04-01 19:28 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-01 19:28:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Mueller 2008-02-26 12:45:50 EST
Description of problem:

Wireshark doesn't launch.  When started from the Gnome menu, nothing happens
after entering the root password.  When run from the command line I get the
following error:

# wireshark
wireshark: symbol lookup error: wireshark: undefined symbol: plugin_list

Version-Release number of selected component (if applicable):

wireshark-0.99.7-2.fc8
wireshark-gnome-0.99.7-2.fc8

Steps to Reproduce:
1. $ su
2. # wireshark
  
Actual results:

wireshark: symbol lookup error: wireshark: undefined symbol: plugin_list

Expected results:

Wireshark application should run.

Additional info:
Comment 1 Radek Vokal 2008-02-26 13:34:23 EST
Very strange, I can't reproduce that on my system. Try to remove ~/.wireshark.
Also have you ever installed wireshark directly from tarball? 
Comment 2 David Mueller 2008-02-26 15:29:17 EST
I tried removing /root/.wireshark and it still gives me the error.  I have built
wireshark (version 0.99.3a) from source but not installed it (I ran configure
and make, but not make install), and it runs fine from the build directory.

I am using the i386 PAE kernel (2.6.23.15-137.fc8PAE) on a MacBook Pro, in case
that makes a difference.
Comment 3 David Mueller 2008-04-01 19:28:55 EDT
Figured out that this was a conflict with some custom code based on Wireshark,
removed that and the Wireshark package works normally.  Marking NOTABUG.

Note You need to log in before you can comment on or make changes to this bug.