Bug 434987 - Email messages with UIDs bigger than 2^31 are unreadable via SquirrelMail
Email messages with UIDs bigger than 2^31 are unreadable via SquirrelMail
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: squirrelmail (Show other bugs)
4.6
i386 Linux
low Severity high
: rc
: ---
Assigned To: Michal Hlavinka
http://sourceforge.net/tracker/index....
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-26 13:36 EST by J Robinson
Modified: 2010-03-05 08:58 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-03-05 08:58:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
don't convert uid to int, keep it as string (7.25 KB, patch)
2009-02-03 04:25 EST, Michal Hlavinka
no flags Details | Diff

  None (edit)
Description J Robinson 2008-02-26 13:36:16 EST
Description of problem:

Email messages with UIDs bigger than 2^31 are unreadable through squirrelmail.

Version-Release number of selected component (if applicable):

dovecot-0.99.11-8.EL4
squirrelmail-1.4.8-4.0.1.el4

How reproducible:

Try to view a message with a UID larger than 2^31.

Steps to Reproduce:
1.Configure squirrelmail to show messages from dovecot using mbox-format
mailboxes via IMAP.
2.Generate a message UID larger than 2^31 via X-UID, X-IMAPbase, X-IMAP or 
Message-ID:  headers. 
3.View the mailbox in squirrelmail. All messages will show up in mailbox view.
4.Click to see a message with a large id. 

Actual results:

You'll get the error ""The server couldn't find the message you requested. Most
probably your message list was out of date and the message has been moved away
or deleted (perhaps by another program accessing the same mailbox)." 

Expected results:

View content of clicked message.

Additional info:

This has caused multiple mailboxes to become completely unreadable via
SquirrelMail on my long-running RHEL 4 setup, as all received email messages are
created with message UIDs larger than 2^31.

Apparently dovecot 1.0 is far less likely to provide message UIDs larger than
2^31.  The core of the problem in squirrelmail seems to be that it handles
message UIDs as numbers, which causes them to be cast to signed integers.
Comment 1 Michal Hlavinka 2009-02-03 04:25:08 EST
Created attachment 330720 [details]
don't convert uid to int, keep it as string

patch has been send upstream:
>> so I wonder what's the destiny of the 1.4 patch?
>
> It will continue to be available in our tracker for people who want
> it, and depending on feedback and team opinions based on how popular
> it is, we may decide at some time in the future that the changes in
> the (stable) code are worth adding.
Comment 2 Michal Hlavinka 2010-03-05 08:58:29 EST
I'm sorry for not addressing the issue in RHEL-4. As squirrelmail
is not scheduled for update in RHEL-4.9, I'm closing that bugzilla WONTFIX. If
you are still experiencing the issue with RHEL-5, feel free to reopen it
against RHEL-5.

Note You need to log in before you can comment on or make changes to this bug.