Bug 435008 - Latest trac depends on i386 python
Latest trac depends on i386 python
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: trac (Show other bugs)
8
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeffrey C. Ollie
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-26 15:08 EST by Alexander Kahl
Modified: 2008-02-28 04:31 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-28 04:31:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexander Kahl 2008-02-26 15:08:00 EST
trac 0.10.4-21 depends on /usr/lib/python2.5/site-packages/neo_cgi.so, which is
provided by python.i386 but not by python.x86_64. If architecture-dependent code
has been added to trac, it mustn't remain a noarch package anymore but provide
packages per architecture instead.
Comment 1 Jeffrey C. Ollie 2008-02-27 23:36:20 EST
neo_cgi.so is not provided by Python, it's provided by the ClearSilver package
which is available for x86_64.  I think that your logic regarding arch/noarch
packages is incorrect.  If you were right, it would be impossible to have any
noarch packages at all.  I think that the problem is that you have the i386
version of python-clearsilver installed but not the x86_64 version.  Try
removing any clearsilver packages and re-installing them.  Unless something is
wrong with your yum configs yum should install the x86_64 versions.
Comment 2 Alexander Kahl 2008-02-28 04:31:14 EST
Sorry Jeffrey, my fault - to my surprise, I just figured out atrpms provides the
faulty trac with arch-dependent python-clearsilver bindings, since I didn't
suspect a 3rd party repo would provide trac (I wonder why??) I filed the bug
here instead of investigating the source.
Thus I'm closing the bug.

Thank you for your good work and maintaining the trac package!

Note You need to log in before you can comment on or make changes to this bug.