Bug 435057 - Can't restart from GNOME menu; can't edit policy settings
Can't restart from GNOME menu; can't edit policy settings
Status: CLOSED DUPLICATE of bug 237621
Product: Fedora
Classification: Fedora
Component: ConsoleKit (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: jmccann
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-26 21:21 EST by Jonathan Kamens
Modified: 2015-01-14 18:20 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-27 21:45:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jonathan Kamens 2008-02-26 21:21:08 EST
With today's Rawhide:

When I select "Shut Down..." from the GNOME panel menu and click "Restart",
nothing happens.

When I go to System > Preferences > System > Authorizations (it surprises me
that I'm allowed to run this program and view authorizations as myself, not
root, without entering the root password) and look at
org.freedesktop.consolekit.Restart the system, it claims that the active console
is allowed to restart.

The restart doesn't work when I run gnome-session as root either.

I am not allowed to edit the PolicyKit settings in the Authorizations GUI,
either as myself or as root.

All in all, things seem to be functioning rather sub-optimally.
Comment 1 David Zeuthen 2008-02-26 23:42:42 EST
(In reply to comment #0)
> With today's Rawhide:
> 
> When I select "Shut Down..." from the GNOME panel menu and click "Restart",
> nothing happens.
>
> When I go to System > Preferences > System > Authorizations (it surprises me
> that I'm allowed to run this program and view authorizations as myself, not
> root, without entering the root password) 

Viewing your own authorizations doesn't require any special privileges. Note
that you can't view other users authorizations unless you have the
org.freedesktop.policykit.read authorization.

> and look at
> org.freedesktop.consolekit.Restart the system, it claims that the active console
> is allowed to restart.
> 
> The restart doesn't work when I run gnome-session as root either.
> 
> I am not allowed to edit the PolicyKit settings in the Authorizations GUI,
> either as myself or as root.
> 
> All in all, things seem to be functioning rather sub-optimally.

What is the output of 

 1. polkit-auth --explicit-detail
 2. ck-list-session

from inside a normal session (not logged in as root).
Comment 2 David Zeuthen 2008-02-26 23:44:05 EST
(btw that would be ck-list-sessions, not ck-list-session)
Comment 3 Jonathan Kamens 2008-02-27 09:53:26 EST
Immediately after attempting to restart from the GNOME menu:

org.pulseaudio.acquire-high-priority
  Authorized:  No
  Scope:       Indefinitely
  Obtained:    Wed Dec 12 06:13:00 2007 by auth as root (uid 0)
  Constraint:  Session must be on a local console
  Constraint:  Session must be active

Session1:
        uid = '0'
        realname = 'root'
        seat = 'Seat1'
        session-type = ''
        active = FALSE
        x11-display = ''
        x11-display-device = ''
        display-device = '/dev/tty1'
        remote-host-name = ''
        is-local = TRUE
        on-since = '2008-02-27T02:12:58Z'
        idle-since-hint = '2008-02-27T02:13:41Z'
Comment 4 David Zeuthen 2008-02-27 12:49:21 EST
It's because your session isn't listed as active. Reassigning to ConsoleKit.
Comment 5 jmccann 2008-02-27 13:17:11 EST
Actually the session isn't listed at all.

How are you logging into GNOME?  GDM, startx, etc?
Comment 6 Jonathan Kamens 2008-02-27 21:28:12 EST
Logging in via xdm (hate the new gdm interface), with ~/.xsession linked to
/usr/bin/gnome-session.
Comment 7 David Zeuthen 2008-02-27 21:45:47 EST

*** This bug has been marked as a duplicate of 237621 ***

Note You need to log in before you can comment on or make changes to this bug.