This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 435068 - the exec() call failed -- system-config-services
the exec() call failed -- system-config-services
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: system-config-services (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Nils Philippsen
Fedora Extras Quality Assurance
:
: 435127 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-26 23:32 EST by Ray Todd Stevens
Modified: 2008-02-29 04:24 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-27 06:23:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Ray Todd Stevens 2008-02-26 23:32:29 EST
Description of problem:

When I try and run system config for the services I get the message 

The exec() call failed.

I am logged in as root.   But if I try and run system-config-services manually I
get permission error.   I think this is because all of the files in
/usr/share/system-config-services are flagged rw and not rwx




Version-Release number of selected component (if applicable):

system-config-services.0.99.0-1.fc9.noarch

How reproducible:

100% on one machine
Comment 1 Ray Todd Stevens 2008-02-26 23:34:19 EST
I ran into this one trying to check and see if 404881 was fixed.
Comment 2 Nils Philippsen 2008-02-27 06:23:59 EST
I've made the Python file in question executable, system-config-services-0.99.1
is building right now with this change.
Comment 3 Nils Philippsen 2008-02-27 11:24:31 EST
*** Bug 435127 has been marked as a duplicate of this bug. ***
Comment 4 antonio montagnani 2008-02-27 11:41:46 EST
 
I downloaded from koji and I get:
system-config-services
(system-config-services:5006): libglade-WARNING **: could not find glade file
'system-config-services.glade'
Traceback (most recent call last):
  File "/usr/sbin/system-config-services", line 617, in <module>
    GUI ().run ()
  File "/usr/sbin/system-config-services", line 602, in __init__
    self.mainWindow = MainWindow (serviceherders = self.serviceherders)
  File "/usr/sbin/system-config-services", line 523, in __init__
    xml = gtk.glade.XML (os.path.join (config.datadir,
NameError: global name 'os' is not defined
Comment 5 Nils Philippsen 2008-02-27 12:12:14 EST
system-config-services-0.99.2 is building right now which should import the
missing module.
Comment 6 Horst H. von Brand 2008-02-28 14:41:22 EST
system-config-services-0.99.2-1.fc9.noarch:

# system-config-services 
Traceback (most recent call last):
  File "/usr/sbin/system-config-services", line 27, in <module>
    import gamin
ImportError: No module named gamin
Comment 7 Nils Philippsen 2008-02-29 04:24:01 EST
Thanks for spotting this. I've added the gamin-python requirement to the spec
file, upcoming versions should have it.In the meantime, you could just install
it manually ;-).

Note You need to log in before you can comment on or make changes to this bug.