Bug 435076 - yum can not continue interrupted download if server do not support partial downloads
yum can not continue interrupted download if server do not support partial do...
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: python-urlgrabber (Show other bugs)
5.2
All Linux
low Severity low
: ---
: ---
Assigned To: James Antill
Fedora Extras Quality Assurance
: Patch
Depends On:
Blocks: 919076 435156
  Show dependency treegraph
 
Reported: 2008-02-27 02:41 EST by Jan Hutař
Modified: 2014-06-09 15:59 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 919076 (view as bug list)
Environment:
Last Closed: 2014-06-02 09:05:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
webserver I have used for testing (1.61 KB, text/plain)
2008-02-27 02:58 EST, Jan Hutař
no flags Details
Adjust the file offset when byte ranges don't work (617 bytes, patch)
2013-12-17 06:32 EST, Zdeněk Pavlas
no flags Details | Diff
Skip the lead when byte ranges didn't work on the server (617 bytes, patch)
2013-12-17 08:04 EST, Zdeněk Pavlas
no flags Details | Diff

  None (edit)
Description Jan Hutař 2008-02-27 02:41:40 EST
Description of problem:
yum downloads broken package if it tries to continue interrupted download from 
server which do not support partial downloads.


Version-Release number of selected component (if applicable):
3.2.8-7.el5


How reproducible:
always


Steps to Reproduce:
1. configure system against RHN Proxi 4.2 (was fixed in 4.2.2)
2. yum linstall something


Actual results:
# yum -y --noplugins --disablerepo=* --enablerepo=myrepo install big-package
...
---> Downloading header for big-package to pack into transaction set.
big-package-0.1-1.noarch. 100% |=========================|  66 kB    00:08     
http://pok.englab.brq.redhat.com/test-rpmbuild-big-package-0.1-1/RPMS/noarch/
big-package-0.1-1.noarch.rpm: [Errno -1] Header is not complete.
Trying other mirror.
Error: failure: test-rpmbuild-big-package-0.1-1/RPMS/noarch/big-
package-0.1-1.noarch.rpm from myrepo: [Errno 256] No more mirrors to try.


Expected results:
download and installation passes


Additional info:
This is related to bug 249710
Comment 2 Jan Hutař 2008-02-27 02:58:24 EST
Created attachment 296028 [details]
webserver I have used for testing

(slightly modified example from
http://fragments.turtlemeat.com/pythonwebserver.php)
Comment 3 James Antill 2008-02-27 08:55:15 EST
 Was this supposed to be against RHEL-5.2?
Comment 6 James Antill 2008-02-27 10:47:14 EST
 So the crux of this problem is that you do a range request, to a server that
doesn't understand them ... so you get back 200 (instead of 206) and the entire
file (instead of the range you wanted).
 This is entirely legal, so we should handle it (Ie. ignore what we have
already, and start again) ... and I'm pretty surprised we don't. I think we just
need to truncate the file in 
HTTPRangeHandler() when we get a 200 response.
Comment 7 Jan Hutař 2008-02-27 17:19:32 EST
Changed "Product" to RHEL-5.2 (main concern here are old RHN Proxies which can 
not do partial download)
Comment 8 Zdeněk Pavlas 2013-03-07 09:52:10 EST
I'm sure this is not fixed upstream..
Comment 9 RHEL Product and Program Management 2013-05-01 02:55:41 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unable to address this
request at this time.

Red Hat invites you to ask your support representative to
propose this request, if appropriate, in the next release of
Red Hat Enterprise Linux.
Comment 10 Zdeněk Pavlas 2013-12-17 06:31:17 EST
According to the code and changelog, reget over broken proxy has been fixed:

* Mon Jul 21 2008 James Antill <jantill@redhat.com> - 3.1.0-4
- reget with HTTP servers that don't support Range

It seems that the reported problem is quite different, and related to RPM header download. But the above fix does not work with byte ranges.  I've made an update that *should* fix this, too.
Comment 11 Zdeněk Pavlas 2013-12-17 06:32:26 EST
Created attachment 837636 [details]
Adjust the file offset when byte ranges don't work
Comment 12 Zdeněk Pavlas 2013-12-17 08:04:12 EST
Created attachment 837663 [details]
Skip the lead when byte ranges didn't work on the server

Last minute changes (renamed variable) suck..
Comment 13 RHEL Product and Program Management 2014-02-24 19:19:13 EST
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unable to address this
request at this time.

Red Hat invites you to ask your support representative to
propose this request, if appropriate, in the next release of
Red Hat Enterprise Linux.
Comment 14 RHEL Product and Program Management 2014-03-07 08:37:26 EST
This bug/component is not included in scope for RHEL-5.11.0 which is the last RHEL5 minor release. This Bugzilla will soon be CLOSED as WONTFIX (at the end of RHEL5.11 development phase (Apr 22, 2014)). Please contact your account manager or support representative in case you need to escalate this bug.
Comment 15 RHEL Product and Program Management 2014-06-02 09:05:35 EDT
Thank you for submitting this request for inclusion in Red Hat Enterprise Linux 5. We've carefully evaluated the request, but are unable to include it in RHEL5 stream. If the issue is critical for your business, please provide additional business justification through the appropriate support channels (https://access.redhat.com/site/support).

Note You need to log in before you can comment on or make changes to this bug.