Bug 435106 - pv guest on 32bit just "hangs" after fresh install
pv guest on 32bit just "hangs" after fresh install
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: xen (Show other bugs)
5.1
All Linux
low Severity low
: rc
: ---
Assigned To: Xen Maintainance List
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-27 07:39 EST by Thorsten Scherf
Modified: 2009-12-14 16:26 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-02 02:38:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xend.log (106.69 KB, text/plain)
2008-02-27 07:39 EST, Thorsten Scherf
no flags Details

  None (edit)
Description Thorsten Scherf 2008-02-27 07:39:50 EST
Description of problem:
I saw this once onsite and now I have the same problem in a lab setup. rhel5.1
system (32bit) with latest updates, fresh rhel5.1 pv guest installation. when i
start up the guest it just "hangs". last line printed out on screen when using
xm console is from auditd. selinux is switched off in dom0. xend.log is
attached. state of the machine is blocked. xm destroy and restart doesn't help. 

Version-Release number of selected component (if applicable):
xen-3.0.3-41.el5

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Thorsten Scherf 2008-02-27 07:39:50 EST
Created attachment 296057 [details]
xend.log
Comment 2 Chris Lalancette 2008-02-27 08:27:41 EST
This is probably not a hang, just a configuration issue.  Did you initially
install the guest with "virt-install --vnc", and then try to connect to it
afterwards with "xm console"?  If that is the case, the thing is that we don't
automatically setup xm console when doing a graphical install, since xm console
is really a serial terminal.  You should be able to get to it using virt-manager
or vncviewer.

If this is not the case, please get the full virt-install command line you used,
as well as the log from the guest console (/var/log/xen/console/guest-<name>;
you'll have to set it up in /etc/sysconfig/xend first).

Chris Lalancette
Comment 3 Thorsten Scherf 2009-01-29 03:34:29 EST
yeah, the machine was installed using virt-install --vnc. How is it possible to setup the serial console afterwards, so that one can use xm console to get access to the machine?
Comment 4 Daniel Berrange 2009-01-29 05:11:09 EST
In the guest you just need to edit /etc/grub.conf to add 'console=xvc0 console=tty'  and also edit /etc/inittab to turn on a agetty process on xvc0. This will cause boot messages to be sent to both text and graphical console, and also start a login prompt on the text console.
Comment 5 Bill Burns 2009-02-27 14:12:20 EST
Did the suggestions abobe help? Can we close this as not a bug? Thanks.
Comment 6 Thorsten Scherf 2009-03-02 01:23:04 EST
yeah, the hint helped. you can close this a NOTABUG.

Note You need to log in before you can comment on or make changes to this bug.