Bug 435111 - Profile checkboxes initialised incorrectly when system-config-network starts
Profile checkboxes initialised incorrectly when system-config-network starts
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: system-config-network (Show other bugs)
8
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Harald Hoyer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-27 08:08 EST by Robin Green
Modified: 2008-05-24 08:37 EDT (History)
1 user (show)

See Also:
Fixed In Version: 1.5.5-1.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-24 08:37:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robin Green 2008-02-27 08:08:03 EST
I have 3 profiles (including Common). I ignore the Common profile, and don't use
it. Whenever I run system-config-network, the checkboxes for one of my profiles
(not Common), are set incorrect (looks like they're set for Common instead of
that profile).

However, when you actually click the checkbox that should be unchecked, to
uncheck it, nothing happens. When you click it a second time, it gets unchecked.
I figured out that the program thinks the checkbox is in the off state, but it
is actually *displaying* as checked.

So my educated guess is, for some reason, it's displaying the checkboxes for the
Common profile, but it thinks it's displaying the checkboxes for the currently
active profile.

If I manually fix this by clicking twice in each checkbox that is displaying
wrong, it stays fixed, until I quit and run system-config-network again.

I am not sure if this actually affects the profiles themselves, i.e. I'm not
sure if it's just a display bug, or if the profiles get saved incorrectly.

Version-Release number of selected component (if applicable):
system-config-network-1.4.7-1.fc8
Comment 1 Harald Hoyer 2008-02-27 08:29:29 EST
Common defines what all profiles have in common, so you can specify interfaces
globally.
Comment 2 Robin Green 2008-02-27 08:48:24 EST
Yes, I am aware of that. However, the bug is that when the *active* profile is
let's say, Home, apparently the checkboxes for Common are displayed.
Comment 3 Harald Hoyer 2008-02-27 10:07:33 EST
ah, ok.. will check
Comment 5 Robin Green 2008-03-27 06:41:54 EDT
(In reply to comment #4)
> Care to betatest?
> http://people.fedoraproject.org/~harald/downloads/system-config-network/1.5.90/
> 

I'll try that over the weekend - thanks!

Comment 6 Harald Hoyer 2008-03-31 06:47:07 EDT
1.5.93 also in
http://people.fedoraproject.org/~harald/downloads/system-config-network/
Comment 7 Robin Green 2008-05-24 08:37:20 EDT
Sorry I didn't have time to look at this earlier. I am no longer seeing this
with the latest version.

Note You need to log in before you can comment on or make changes to this bug.