Bug 435116 - fontflags missing in pdftex_ndl14.map for non-embedded base14 pdf fonts
fontflags missing in pdftex_ndl14.map for non-embedded base14 pdf fonts
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: texlive-texmf (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Jindrich Novy
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-27 09:09 EST by Bob T.
Modified: 2013-07-02 19:27 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-13 15:38:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
.tex file to test the base 14 pdf fonts (465 bytes, text/plain)
2008-03-01 08:49 EST, Bob T.
no flags Details

  None (edit)
Description Bob T. 2008-02-27 09:09:44 EST
Description of problem:

If one specifies pdftexDownloadBase14 false in updmap.cfg, the pdftex.map should
have "fontflags" for the base 14 fonts; otherwise warning messages
are generated:


pdfTeX warning: pdflatex: No flags specified for non-embedded font
`Times-Roman' (ptmr8r) (I'm using 34): fix your map entry.

Font flags are described in the pdftex manual.


Version-Release number of selected component (if applicable):

texlive-texmf-2007-10.fc9


How reproducible:

Always


Steps to Reproduce:
1. use any of the base 14 fonts (Times, Helvetica, ...) in a document
2. process using pdflatex
3.
  
Actual results:

Warning messages.


Expected results:

No warning messages.

Additional info:


The appropriate pdftex_ndl14.map entries would be

ptmr8r Times-Roman 34 "TeXBase1Encoding ReEncodeFont" <8r.enc

ptmb8r Times-Bold 262178 "TeXBase1Encoding ReEncodeFont" <8r.enc

ptmbi8r Times-BoldItalic 262242 "TeXBase1Encoding ReEncodeFont" <8r.enc

ptmri8r Times-Italic 98 "TeXBase1Encoding ReEncodeFont" <8r.enc

phvr8r Helvetica 32 "TeXBase1Encoding ReEncodeFont" <8r.enc

phvb8r Helvetica-Bold 262176 "TeXBase1Encoding ReEncodeFont" <8r.enc

phvbo8r Helvetica-BoldOblique 262240 "TeXBase1Encoding ReEncodeFont" <8r.enc

phvro8r Helvetica-Oblique 96 "TeXBase1Encoding ReEncodeFont" <8r.enc


Possibly the ptmr8y etc. lines should be similarly modified; I don't know what
they're for.
Comment 1 Bob T. 2008-02-27 11:16:34 EST
Additional revisions for Courier, Dingbat and Symbol fonts:

pcrb8r Courier-Bold  262179 "TeXBase1Encoding ReEncodeFont" <8r.enc
pcrbo8r Courier-BoldOblique  262243 "TeXBase1Encoding ReEncodeFont" <8r.enc
pcrr8r Courier 35 "TeXBase1Encoding ReEncodeFont" <8r.enc
pcrro8r Courier-Oblique  99 "TeXBase1Encoding ReEncodeFont" <8r.enc
pzdr ZapfDingbats 4
psyr Symbol 4
Comment 2 Bob T. 2008-02-27 11:38:09 EST
The map file that should be corrected is

/usr/share/texmf/fonts/map/dvips/tetex/pdftex35.map

which belongs to the texlive-texmf-dvips-2007 package.
Comment 3 Jindrich Novy 2008-03-01 07:18:29 EST
Thanks for the fontflags descriptions. May I ask how did you acquire them?
Comment 4 Bob T. 2008-03-01 08:49:58 EST
Created attachment 296452 [details]
.tex file to test the base 14 pdf fonts

When processed by pdflatex, warning messages will say which fontflags are
assumed if not provided by pdftex.map.
Comment 5 Bob T. 2008-03-13 15:38:00 EDT
To be fixed upstream (texlive):

 >|After some discussion with Martin and Hartmut, the result was that the
 >|best approach would be for pdftex *not* to warn about the flags missing
 >|for the "base14" fonts when unembedded, since it already knows exactly
 >|what flags to use.  (It's rather nontrivial to add the flags to the map
 >|file(s), due to all the tools involved.)  This will be in the next
 >|pdftex release.
 >|
 >|However, it will (as I understand it) continue to warn about any other
 >|fonts which are unembedded without flags.  There are none such in TeX
 >|Live, as far as I know.
 >|
 >|Karl Berry

Note You need to log in before you can comment on or make changes to this bug.