Bug 435124 - Logjam freezes
Logjam freezes
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: logjam (Show other bugs)
8
i386 Linux
low Severity high
: ---
: ---
Assigned To: Tom "spot" Callaway
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-27 10:20 EST by Peter Janakiev
Modified: 2008-04-04 05:25 EDT (History)
0 users

See Also:
Fixed In Version: 4.5.3-22.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-26 13:17:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Janakiev 2008-02-27 10:20:26 EST
Description of problem:
When you try to edit something in the text buffer in order to apply a HTML tag /
formatting (like <i> or <b>) the application freezes and need to be killed to
terminate. 


Version-Release number of selected component (if applicable):
logjam-4.5.3-9.fc8.3

How reproducible:
Always

Steps to Reproduce:
1.Start logjam from terminal or from menu
2.Write something in the text buffer, then select it 
3.From the menu select HTML and then something there like Italic for example
  
Actual results:
The application freezes

Expected results:
enclose the buffer in the tag selected

Additional info:
It seems like we get trapped in some system call, but i am not that good with
GDB and cannot tell for sure, fact is it appeared recently, the version has not
really changed soon, it was working okay before.
Comment 1 Tom "spot" Callaway 2008-02-28 11:56:26 EST
Confirmed, does that in rawhide as well. Might be gtkhtml related.
Comment 2 Fedora Update System 2008-03-11 20:38:25 EDT
logjam-4.5.3-19.fc7 has been submitted as an update for Fedora 7
Comment 3 Fedora Update System 2008-03-11 20:41:48 EDT
logjam-4.5.3-19.fc8 has been submitted as an update for Fedora 8
Comment 4 Tom "spot" Callaway 2008-03-11 20:47:14 EDT
Please try this release, it resolves the crasher on my end.

F-7: http://koji.fedoraproject.org/koji/buildinfo?buildID=42633
F-8: http://koji.fedoraproject.org/koji/buildinfo?buildID=42632
Comment 5 Fedora Update System 2008-03-13 03:41:24 EDT
logjam-4.5.3-19.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update logjam'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F7/FEDORA-2008-2394
Comment 6 Peter Janakiev 2008-03-13 06:06:14 EDT
The "no threads" patch is not good, when you press the "tags" button it make the
app crash with SIGABR because Glib says the threads has not been initialized.

Rebuild of the rpm with this patch disabled in the spec file resolves the issue
for me. Everything else seems to work, HTML tags work again. 
Comment 7 Tom "spot" Callaway 2008-03-13 07:34:30 EDT
Do you have assistive technologies turned on?

System -> Preferences -> Assistive Technologies -> Enable Assistive Technologies

We were only able to trigger this bug with that enabled, and never able to
trigger it with it disabled.
Comment 8 Peter Janakiev 2008-03-13 07:51:13 EDT
/desktop/gnome/interface/accessibility is false if that is what you are asking.

It was turned on while ago for few days (so my mom can try the magnification) -
it was then turned off and now it is off.

Anything else I can help with?
Comment 9 Tom "spot" Callaway 2008-03-13 08:19:18 EDT
Turn it on, logout of X, then login again. Try to reproduce your crasher case
without the threading patch. Let me know what happens. :)
Comment 10 Peter Janakiev 2008-03-13 08:57:24 EDT
Tests:
1. Accessibility ENABLED
--with threading - crashes on HTML formatiing
--without threading (meaning with the patch included) - works fine 
2. Accessibility DISABLED
--with threading - works fine
--without threading (meaning with the patch included) - crashes on TAG button
pressed.

Can we have a release that works with and without the accessibility option?
Comment 11 Fedora Update System 2008-03-18 18:04:40 EDT
logjam-4.5.3-22.fc7 has been submitted as an update for Fedora 7
Comment 12 Fedora Update System 2008-03-18 18:05:25 EDT
logjam-4.5.3-22.fc8 has been submitted as an update for Fedora 8
Comment 13 Tom "spot" Callaway 2008-03-18 18:18:30 EDT
-22 should fix all the possible test cases, please let me know if it does not.
Comment 14 Tom "spot" Callaway 2008-03-24 14:01:56 EDT
I'll assume from your silence that it works for you (it works for me). Pushing
-22 to stable.
Comment 15 Peter Janakiev 2008-03-24 15:39:27 EDT
Sorry i was away for few days this is why i have delayed the tests:

Accessability option disabled -> crashes badly upon pressing the TAGs button:

GLib-ERROR **: The thread system is not yet initialized.
aborting...
61118e3e-b6db-5ca3-71e86c28-44391c3b is dumped

So same as before. 
Isn't it duplicable on any fedora8 installation? I mean 
System: Linux 2.6.24.3-34.fc8 #1 SMP Wed Mar 12 18:17:20 EDT 2008 i686
X Vendor: The X.Org Foundation
X Vendor Release: 10300000
Selinux: Permissive
Accessibility: Disabled
GTK+ Theme: new
Icon Theme: Tango
 is what I use and when i tart and press the TAG button (...) it crashes. I know
some themes can crash an app so i tryed with different themes, including a
default clearlooks. It still crashes. 
Comment 16 Tom "spot" Callaway 2008-03-24 16:09:00 EDT
Hmm. I can't reproduce this on my i686 F-8 test system at all.
Comment 17 Tom "spot" Callaway 2008-03-24 16:10:15 EDT
Can you send me your .logjam/conf.xml?
Comment 18 Peter Janakiev 2008-03-25 03:31:22 EDT
conf.xml (nothing interesting there really):

<?xml version="1.0"?>
<configuration version="1">
  <currentserver>LiveJournal.com</currentserver>
  <geometries>
    <geometry window="main">
      <x>370</x>
      <y>113</y>
      <width>560</width>
      <height>453</height>
    </geometry>
    <geometry window="manager">
      <x>361</x>
      <y>284</y>
      <width>303</width>
      <height>200</height>
    </geometry>
    <geometry window="preview">
      <x>380</x>
      <y>182</y>
      <width>500</width>
      <height>400</height>
    </geometry>
  </geometries>
  <options>
    <usespellcheck/>
    <revertusejournal/>
    <docklet/>
    <smartquotes/>
    <showmeta>
      <picture/>
      <music/>
      <tags/>
      <preformatted/>
      <comments/>
    </showmeta>
  </options>
  <uifont>Liberation Sans 12</uifont>
  <spell_language>bg</spell_language>
  <spawncommand>gnome-open '%s'</spawncommand>
  <musiccommand>rhythmbox-client --print-playing</musiccommand>
  <cfuserinterval>45</cfuserinterval>
  <cfthreshold>1</cfthreshold>
</configuration>
Comment 19 Fedora Update System 2008-03-26 13:16:12 EDT
logjam-4.5.3-22.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 20 Fedora Update System 2008-03-26 13:17:14 EDT
logjam-4.5.3-22.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 21 Peter Janakiev 2008-04-03 15:29:34 EDT
System: Linux 2.6.24.4-64.fc8 #1 SMP Sat Mar 29 09:54:46 EDT 2008 i686
X Vendor: The X.Org Foundation
X Vendor Release: 10300000
Selinux: Permissive
Accessibility: Disabled
GTK+ Theme: new
Icon Theme: Tango

Memory status: size: 0 vsize: 0 resident: 0 share: 0 rss: 0 rss_rlim: 0
CPU usage: start_time: 0 rtime: 0 utime: 0 stime: 0 cutime:0 cstime: 0 timeout:
0 it_real_value: 0 frequency: 0

----------- .xsession-errors (99 sec old) ---------------------
(process:6830): GLib-GObject-WARNING **: invalid (NULL) pointer instance
(process:6830): GLib-GObject-CRITICAL **: g_signal_connect_data: assertion
`G_TYPE_CHECK_INSTANCE (instance)' failed
GLib-ERROR **: The thread system is not yet initialized.
aborting...

MDRawSystemInfo
  processor_architecture                     = 0
  processor_level                            = 2
  processor_revision                         = 0xd08
  number_of_processors                       = 1
  product_type                               = 0
  major_version                              = 0
  minor_version                              = 0
  build_number                               = 0
  platform_id                                = 33281
  csd_version_rva                            = 0x10cf8
  suite_mask                                 = 0x0
  cpu.x86_cpu_info.vendor_id[0]              = 0x756e6547
  cpu.x86_cpu_info.vendor_id[1]              = 0x49656e69
  cpu.x86_cpu_info.vendor_id[2]              = 0x6c65746e
  cpu.x86_cpu_info.version_information       = 0x0
  cpu.x86_cpu_info.feature_information       = 0x0
  cpu.x86_cpu_info.amd_extended_cpu_features = 0x0
  (csd_version)                              = "Linux 2.6.24.4-64.fc8 #1 SMP Sat
Mar 29 09:54:46 EDT 2008 i686 GNU/Linux"
  (cpu_vendor)                               = "GenuineIntel"

I dont know what else should I include?
rpm -q logjam
logjam-4.5.3-22.fc8
Comment 22 Tom "spot" Callaway 2008-04-03 15:58:48 EDT
Can you do me a favor:

yum remove logjam

(then, make sure you don't have any logjam files anywhere else)

yum install logjam.i386

Then, try to reproduce.

Also, you're just clicking the "..." button next to tags? Do you have a lot of tags?
Comment 23 Peter Janakiev 2008-04-04 05:25:45 EDT
After removing the ~/.logjam directory it works. I don't know what the reason
was, maybe some accels or anything else. Thanks for the help.

Note You need to log in before you can comment on or make changes to this bug.