Bug 435169 - IA64 Xen VTI Windows domain can not boot up with >14G memory
IA64 Xen VTI Windows domain can not boot up with >14G memory
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: xen-ia64-guest-firmware (Show other bugs)
5.2
All Linux
high Severity high
: rc
: ---
Assigned To: Jarod Wilson
Virtualization Bugs
: OtherQA
Depends On:
Blocks: 245607
  Show dependency treegraph
 
Reported: 2008-02-27 13:41 EST by Adam Stokes
Modified: 2010-10-22 18:51 EDT (History)
8 users (show)

See Also:
Fixed In Version: RHBA-2008-0448
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-21 12:49:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
firmware update (1.32 MB, application/x-rpm)
2008-02-27 13:41 EST, Adam Stokes
no flags Details
The VTI guest firmware update for RHEL5.2 (1.32 MB, application/x-rpm)
2008-02-27 20:09 EST, You, Yongkang
no flags Details

  None (edit)
Description Adam Stokes 2008-02-27 13:41:32 EST
Description of problem:
If assign >14G memory for a VTI Windows 2k3 domain, Windows can not boot up.
Linux Guest won't have this issue.

How reproducible:
Everytime

Steps to Reproduce:
1) Create a win2k3 disk image of size >=4G if necessary.   
 2) Make sure totally available physical memory of system >= 15000M
 3) Create configuration file for the windows guest HVM to be created
 4) Create windows guest
   # xm create <windows config name>

Actual results:
VTI Windows guest can not correctly boot up with >14G memory.

Expected results:
VTI Windows guest can correctly boot up with >14G memory.
Comment 1 Adam Stokes 2008-02-27 13:41:33 EST
Created attachment 296103 [details]
firmware update
Comment 4 RHEL Product and Program Management 2008-02-27 14:47:15 EST
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 7 Jarod Wilson 2008-02-27 15:49:04 EST
Comment on attachment 296103 [details]
firmware update

ugh. a binary blob is NOT a patch attachment. attempting to fix...
Comment 10 You, Yongkang 2008-02-27 20:09:16 EST
Created attachment 296146 [details]
The VTI guest firmware update for RHEL5.2

Hi all,

I found the former attachment is already obsolete. 
Please use the new update guest firmware.
xen-ia64-guest-firmware-1.0.0-13.src.rpm
Comment 11 You, Yongkang 2008-02-27 20:43:01 EST
Add Fred and Tetsu in the CC list. 
Comment 12 You, Yongkang 2008-02-27 20:49:20 EST
Comment on attachment 296146 [details]
The VTI guest firmware update for RHEL5.2

change the MIME type to application/rpm
Comment 13 Fred Yang 2008-02-28 13:29:24 EST
Adding Bill

Critical fix for IA64 needed in RHEL5.2 for Windows guest - OEMs are directly 
depending on this fix, adding detail information bellow
  a. GFW in RHEL5.1 release can only support upto 14GB which is a limition to 
IA64 system
  b. Tetsu has got a very good result on this GFW with the following results -
      1. Verified RHEL5.1 in running Windows guest upto 60GB (upper limit of 
RHEL5.1)
      2. Verified on RHEL5.2 in running Windows  upto 256GB

  
Comment 15 Jarod Wilson 2008-02-28 14:48:18 EST
Assigning this bug over to me, since I'm the RH package owner for
xen-ia64-guest-firmware. Currently testing it out w/my hp rx2660.
Comment 16 Bill Burns 2008-02-28 15:08:56 EST
Set dev ack, requesting exception based on comment #13.
Partner testing required.
Comment 19 Jarod Wilson 2008-02-28 15:55:56 EST
Package built, working on filing errata request for QE.
Comment 21 Tetsu Yamamoto 2008-02-28 23:28:39 EST
I've tested the updated rpm package of GFW with kernel -83 and confirmed that
Windows guest with 256GB memory can boot up.
Comment 23 John Poelstra 2008-03-20 23:52:02 EDT
Greetings Red Hat Partner,

A fix for this issue should be included in the latest packages contained in
RHEL5.2-Snapshot1--available now on partners.redhat.com.  

Please test and confirm that your issue is fixed.

After you (Red Hat Partner) have verified that this issue has been addressed,
please perform the following:
1) Change the *status* of this bug to VERIFIED.
2) Add *keyword* of PartnerVerified (leaving the existing keywords unmodified)

If this issue is not fixed, please add a comment describing the most recent
symptoms of the problem you are having and change the status of the bug to ASSIGNED.

If you are receiving this message in Issue Tracker, please reply with a message
to Issue Tracker about your results and I will update bugzilla for you.  If you
need assistance accessing ftp://partners.redhat.com, please contact your Partner
Manager.

Thank you
Comment 24 John Poelstra 2008-04-02 17:34:49 EDT
Greetings Red Hat Partner,

A fix for this issue should be included in the latest packages contained in
RHEL5.2-Snapshot3--available now on partners.redhat.com.  

Please test and confirm that your issue is fixed.

After you (Red Hat Partner) have verified that this issue has been addressed,
please perform the following:
1) Change the *status* of this bug to VERIFIED.
2) Add *keyword* of PartnerVerified (leaving the existing keywords unmodified)

If this issue is not fixed, please add a comment describing the most recent
symptoms of the problem you are having and change the status of the bug to ASSIGNED.

If you are receiving this message in Issue Tracker, please reply with a message
to Issue Tracker about your results and I will update bugzilla for you.  If you
need assistance accessing ftp://partners.redhat.com, please contact your Partner
Manager.

Thank you
Comment 25 John Poelstra 2008-04-09 18:41:46 EDT
Greetings Red Hat Partner,

A fix for this issue should be included in the latest packages contained in
RHEL5.2-Snapshot4--available now on partners.redhat.com.  

Please test and confirm that your issue is fixed.

After you (Red Hat Partner) have verified that this issue has been addressed,
please perform the following:
1) Change the *status* of this bug to VERIFIED.
2) Add *keyword* of PartnerVerified (leaving the existing keywords unmodified)

If this issue is not fixed, please add a comment describing the most recent
symptoms of the problem you are having and change the status of the bug to ASSIGNED.

If you are receiving this message in Issue Tracker, please reply with a message
to Issue Tracker about your results and I will update bugzilla for you.  If you
need assistance accessing ftp://partners.redhat.com, please contact your Partner
Manager.

Thank you
Comment 26 John Poelstra 2008-04-23 13:39:22 EDT
Greetings Red Hat Partner,

A fix for this issue should be included in the latest packages contained in
RHEL5.2-Snapshot6--available now on partners.redhat.com.  

We are nearing GA for 5.2 so please test and confirm that your issue is fixed ASAP.

After you (Red Hat Partner) have verified that this issue has been addressed,
please perform the following:
1) Change the *status* of this bug to VERIFIED.
2) Add *keyword* of PartnerVerified (leaving the existing keywords unmodified)

If this issue is not fixed, please add a comment describing the most recent
symptoms of the problem you are having and change the status of the bug to ASSIGNED.

If you are receiving this message in Issue Tracker, please reply with a message
to Issue Tracker about your results and I will update bugzilla for you.  If you
need assistance accessing ftp://partners.redhat.com, please contact your Partner
Manager.

Thank you
Comment 27 You, Yongkang 2008-04-25 05:02:20 EDT
Verify the fixing guest firmware is already in Snapshot4 Supplementary CD .
Comment 29 errata-xmlrpc 2008-05-21 12:49:11 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0448.html

Note You need to log in before you can comment on or make changes to this bug.