Bug 435173 - Traceback when performing CDROM install on iBFT enabled iSCSI system
Traceback when performing CDROM install on iBFT enabled iSCSI system
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: anaconda (Show other bugs)
5.2
i386 Linux
low Severity low
: rc
: ---
Assigned To: Martin Sivák
James Laska
:
Depends On: 438092
Blocks: 223404 RHEL5u2_relnotes RHEL5u3_relnotes
  Show dependency treegraph
 
Reported: 2008-02-27 14:03 EST by James Laska
Modified: 2013-09-02 02:24 EDT (History)
10 users (show)

See Also:
Fixed In Version: RHBA-2008-0397
Doc Type: Bug Fix
Doc Text:
(all architectures) When installing from CD-ROM or DVD-ROM on a system with an iBFT-configured network device, Anaconda will not include any iBFT-configured storage devices unless networking is configured. To enable networking for the installation, use the command linux updates=http:// [any] at the installation boot prompt. Note that [any] can be replaced with any URL. If your system requires a static IP configuration, use the command linux updates=http:// [any] ip= [IP address] netmask= [netmask] dns= [dns] .
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-21 11:33:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Eliminate the traceback, when there is no network (947 bytes, patch)
2008-03-20 10:02 EDT, Martin Sivák
no flags Details | Diff
anaconda.log from VERIFIED test run (509.06 KB, text/plain)
2008-04-04 16:56 EDT, James Laska
no flags Details

  None (edit)
Description James Laska 2008-02-27 14:03:56 EST
Steps to reproduce:
1) Booting from RHEL5.2-Server-20080225.2-i386-DVD.iso
2) At syslinux prompt, type "linux rescue"
3) observer traceback

Running anaconda, the Red Hat Enterprise Linux Server rescue mode - please wait...
Traceback (most recent call last):
  File "/usr/bin/anaconda", line 721, in ?
    anaconda.id = instdata.InstallData(anaconda, [], "fd0", anaconda.methodstr,
opts.display_mode)
  File "/usr/lib/anaconda/instdata.py", line 317, in __init__
    self.reset()
  File "/usr/lib/anaconda/instdata.py", line 56, in reset
    self.iscsi = iscsi.iscsi()
  File "/usr/lib/anaconda/iscsi.py", line 183, in __init__
    self.startup()
  File "/usr/lib/anaconda/iscsi.py", line 355, in startup
    t.startNode(node)
  File "/usr/lib/anaconda/iscsi.py", line 120, in startNode
    log.debug("iscsiadm %s" %(string.join(argv),))
  File "/usr/lib/python2.4/string.py", line 318, in join
    return sep.join(words)
TypeError: sequence item 5: expected string, NoneType found
install exited abnormally [1/1]
sending termination signals...done
sending kill signals...done
disabling swap...
unmounting filesystems...
        /mnt/runtime done
        disabling /dev/loop0
        /proc/bus/usb done
        /proc done
        /dev/pts done
        /sys done
        /tmp/ramfs done
        /mnt/source done
        /selinux done
you may safely reboot your system
Comment 2 James Laska 2008-02-27 14:58:21 EST
I believe the failure case here is booting stage#2 off of a local media source
(hd or disk).  Not network is available, but it attempts to initiate iscsi.

Should it prompt for networking details?
Should it not attempt to initialize iSCSI?
Comment 3 Peter Jones 2008-03-11 09:29:44 EDT
The ideal behavior is to bring the network up with the data that's in the iBFT.
Comment 10 Martin Sivák 2008-03-19 08:52:03 EDT
I guess the dependency should be filled in the opposite direction (this bug
requires the iscsiadm change)
Comment 11 Martin Sivák 2008-03-20 10:02:42 EDT
Created attachment 298694 [details]
Eliminate the traceback, when there is no network

This is first part of the fix. It should eliminate the traceback. There won't
be any iscsi device configured though.

The second part should use the networking information from the iBFT to setup
networking for the iscsi subsystem. With that we are waiting for updates
iscsiadm tool and it will require some nontrivial changes to the networking
code in stage2. So I believe that postponing it for 5.3 is the right way to do.
Comment 13 James Laska 2008-03-20 10:55:19 EDT
Tested proposed patch using msivak-provided updates.img 
 - Booted RHEL5.2-Client-20080313.0/x86_64 DVD
 - loaded updates.img from USB key
 - stage#2 starts without error
 - When transitioning to stage#2 disk screen
   * "starting iSCSI initiator" dialog appears
   * Observed iscsiadm probe fail as expected on tty3 (no networking configured)
   * Disk shows *only* the local system disks (expected when no networking)
 - installation completes without error installing to local system disks

Comment 17 Martin Sivák 2008-03-25 17:50:21 EDT
Fixed in anaconda 11.1.2.110
Comment 19 Don Domingo 2008-03-26 21:27:59 EDT
James, regarding the release note for this (comment #12): can you provide me
with the exact command users should use during install? I'm not entirely sure
how to instruct users on how to "provide networking information". Should users
use the ksdevice option? also, does this mean that users with iFBT-enabled
systems can only install using a pre-written Kickstart or thru the command-line
(text-only?) install mode? 
Comment 21 Don Domingo 2008-04-01 22:15:28 EDT
Hi,
the RHEL5.2 release notes will be dropped to translation on April 15, 2008, at
which point no further additions or revisions will be entertained.

a mockup of the RHEL5.2 release notes can be viewed at the following link:
http://intranet.corp.redhat.com/ic/intranet/RHEL5u2relnotesmockup.html

please use the aforementioned link to verify if your bugzilla is already in the
release notes (if it needs to be). each item in the release notes contains a
link to its original bug; as such, you can search through the release notes by
bug number.

Cheers,
Don
Comment 22 James Laska 2008-04-04 16:54:10 EDT
VERIFIED fix with RHEL5.2-Client-20080402.0/i386 DVD

PASSED - DVD Install
=====================================
1) Boot DVD *
2) Proceed through partitioning (iscsi disk probed but not found due to no
networking)
3) Complete installation

[*] the cmdline parameter "text" was used as the system under test has an
unsupported graphics adapter

PASSED - DVD Rescue-mode (w/o networking)
=====================================
1) Boot DVD with the cmdline arguments: linux rescue
2) entered language/keymap
3) don't start networking when prompted
4) continue with disk probe
5) select OK for a shell

PASSED - DVD Rescue-mode (with networking)
=====================================
1) Boot DVD with the cmdline arguments: linux rescue
2) entered language/keymap
3) start networking when prompted **
4) continue with disk probe
5) select OK for a shell

[**] a minor networking prompt issue was discovered.  This will be filed
separately and is unrelated to iSCSI or iBFT
Comment 23 James Laska 2008-04-04 16:56:50 EDT
Created attachment 301341 [details]
anaconda.log from VERIFIED test run

Attaching anaconda.log from successful test run on
RHEL5.2-Client-20080402.0/i386
Comment 24 James Laska 2008-04-07 07:30:07 EDT
Please note, the rescue mode networking issue reported in comment#22 is being
tracked as bug#435978
Comment 34 errata-xmlrpc 2008-05-21 11:33:17 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0397.html
Comment 35 Ryan Lerch 2008-08-06 20:47:11 EDT
Tracking this bug for the Red Hat Enterprise Linux 5.3 Release Notes.
Comment 36 Ryan Lerch 2008-08-06 20:47:11 EDT
Release note added. If any revisions are required, please set the 
"requires_release_notes" flag to "?" and edit the "Release Notes" field accordingly.
All revisions will be proofread by the Engineering Content Services team.

Note You need to log in before you can comment on or make changes to this bug.