Bug 435179 - Virtualization Documentation.
Virtualization Documentation.
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: Virtualization_Guide (Show other bugs)
5.1
All Linux
medium Severity high
: rc
: ---
Assigned To: Christopher Curran
Content Services Development
: Documentation
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-27 14:23 EST by Norman Mark St. Laurent
Modified: 2013-08-19 20:18 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-02 00:56:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Norman Mark St. Laurent 2008-02-27 14:23:23 EST
Description of problem:
Big Government Customers are complaining about the Virtualization Guide, and the
fact that it is not current and complete.  Customer would like to put a guide to
the installation of the OS's that Xen can run (i.e., all versions of Windows).


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.  Latest down load of the virt guide on Red Hat web site.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Don Domingo 2008-02-27 18:26:54 EST
reassigning to Chris Curran, who is working on a major revamp of the Virt-Guide
Comment 2 Christopher Curran 2008-02-27 21:34:49 EST
Define all version of windows... The new virt
guide(https://engineering.redhat.com/docbot/en-US/Red_Hat_Enterprise_Linux/5.2/html-single/Virtualization_Cookbook/)
has a detailed example of installing XP. I could probably get information on
installing Server 2003 as well as it's much the same as installing XP. By memory
95/98 is very easy to install with QEMU so it's probably just as easy on Xen
making it a pretty trivial task for me to add based on what I know. NT4 is much
harder but still possible. Vista is one which I have no idea about but I've
heard people can get it running.

There is a capatcha between it being possible to document and being able to
document it. At the moment I am pushin for an almost complete version to be
inserted into snapshot 3 of 5.2 on the 13th of March. I have been given an ACK
to exceed that and go to the next snapshot which is on the 21st of March but at
the cost of becoming a blocker for RHEL 5.2. Do you want this bug fixed for 5.2?
I estimate there is around 5 days of work plus tech review in addition to the
present bug fixes and feature requests. This would be a bit of a time blowout
for 5.2 but if you can get the ACKs and permissions I can make it happen.
Comment 3 Norman Mark St. Laurent 2008-02-27 22:07:06 EST
The more examples of windows versions we can have in the documentation the
better.  We have been competing with VMWare, and have a significant government
following using Xen.  As this becomes operational Documentation like "Security
Features Users Guides" and "Privileged Users Guides" will need to be filled out
as a requirement for system admins, security engineers, and information security
officers.

These government documents pull the needed items from our manuals.

Every customer I have has asked for better documentation.  I do not think there
is a time date, but if we are showing progress, that would be great.  XEN
because of its performance will be running windows.  There is a great need to
document this, especially if we have to hit a hidden F5 to load... etc...  etc.

Thanks.
Comment 4 Christopher Curran 2008-02-27 23:23:31 EST
So the real question now is whether the previous document meets the level of
progress we are looking for for this release. If there is such a big impact on
customers it is possible I could get assigned to add even more information to
the documentation on this particular topic. The problem is one of resources
though so I suggest we add Mike (and possibly Paul Gampe) into the thread.
Comment 5 Norman Mark St. Laurent 2008-02-28 07:23:43 EST
We are selling Xen  hard against vmware and zones.  Any edge we have helps. 
Proper up dated documentation is very important to the end user.  Thks.
Comment 6 Michael Hideo 2008-03-03 19:16:16 EST
Hi Norman,

5.2 will deliver:

Windows XP and Windows Server 2003 SP1

Can you give me a priority listing of Windows OSs that you would like us to
document and we will begin documenting the R&D effort in that order.

Cheers,
Mike
Comment 7 Norman Mark St. Laurent 2008-03-03 21:17:40 EST
NT 4.0 and 2000 are also big on the list.  I would also gather vista, but I have
not had a request yet for vista.

Best regards,
Comment 9 Tony Fu 2008-09-23 19:49:04 EDT
User mstlaure@redhat.com's account has been closed
Comment 10 Christopher Curran 2008-10-26 21:47:04 EDT
Without dedicated engineering assistance this bug cannot be fixed. This bug requires subject matter expert assistance.
Comment 11 Christopher Curran 2009-08-06 02:52:42 EDT
Windows 2008 is included. NT is no longer supported by MS and we do not officially support it. All supported versions of Windows are documented now.

Note You need to log in before you can comment on or make changes to this bug.