Bug 435207 - xorg freezes by keyboard input
xorg freezes by keyboard input
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
rawhide
All Linux
low Severity urgent
: ---
: ---
Assigned To: Dave Airlie
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-27 17:36 EST by Steve
Modified: 2008-03-05 10:49 EST (History)
2 users (show)

See Also:
Fixed In Version: 1.4.99.900-0.28.20080304.fc9.i386
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-05 10:49:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg.0.log (34.66 KB, text/plain)
2008-02-27 17:36 EST, Steve
no flags Details
/var/log/gdm/:0.log (14.86 KB, text/plain)
2008-03-02 03:57 EST, Steve
no flags Details

  None (edit)
Description Steve 2008-02-27 17:36:35 EST
Description of problem:
Either gdm or the desktop (after init 3 and startx), by any keyboard inbut X
freezes. The Videocard is an Ati Radeon 9800 Pro.

--- messages ---
[drm:radeon_cp_reset] *ERROR* radeon_cp_reset called without lock held, held  0
owner ea000150 ea000150
[drm:radeon_cp_start] *ERROR* radeon_cp_start called without lock held, held  0
owner ea000150 ea000150
[drm:radeon_cp_idle] *ERROR* radeon_cp_idle called without lock held, held  0
owner ea000150 ea000150
--- messages ---


Version-Release number of selected component (if applicable):
xorg-x11-server-Xorg-1.4.99.1-0.23.20080222.fc9.i386
xorg-x11-drv-ati-6.8.0-2.fc9.i386

How reproducible:


Steps to Reproduce:
1.Start the Computer with gdm or after init 3 with startx.
2.With gdm try to type something and look how X freezes
3.OR On the Desktop start any application, try to type something and look how X
freezes
  
Actual results:
There is no way to use the computer afterwards

Expected results:
It should not freeze 

Additional info:
Comment 1 Steve 2008-02-27 17:36:35 EST
Created attachment 296135 [details]
Xorg.0.log
Comment 2 Steve 2008-03-02 03:57:15 EST
Since a few days there is no more screen (no signal) with the ati driver. So I
switched to vesa and have screen again. Now, gdm is no more freezing. Instead of
freezing, its reloading. There are some interesting messages like "No Symbols
named "de_nodeadkeys" in the include file "us"" in the gdm-log.
Comment 3 Steve 2008-03-02 03:57:48 EST
Created attachment 296488 [details]
/var/log/gdm/:0.log
Comment 4 Steve 2008-03-03 14:42:11 EST
With todays update, X is no longer freezing and the screen is here again with
the ati driver. Now, by keyboard input, gdm it is restarting again and again.
The errors in the system-log are the same:

---
Mar  3 19:28:59 StarsEnd kernel: [drm:radeon_cp_start] *ERROR* radeon_cp_start
called without lock held, held  0 owner f4089a50 f4089a50
Mar  3 19:28:59 StarsEnd kernel: [drm:radeon_cp_idle] *ERROR* radeon_cp_idle
called without lock held, held  0 owner f4089a50 f4089a50
Mar  3 19:28:59 StarsEnd kernel: [drm:radeon_cp_reset] *ERROR* radeon_cp_reset caled
---

Also the one in the gdm-log, like:

---
(II) XINPUT: Adding extended input device "USB Keyboard" (type: KEYBOARD)
The XKEYBOARD keymap compiler (xkbcomp) reports:
> Error:            No Symbols named "de_nodeadkeys" in the include file "us"
>                   Exiting
>                   Abandoning symbols file "default"
Errors from xkbcomp are not fatal to the X server
evdev: leds are 0x0 for device 5
---
Comment 5 Steve 2008-03-05 10:49:46 EST
Seems to be fixed now..

Note You need to log in before you can comment on or make changes to this bug.