Bug 435215 - yumdownloader with --resolve fails with TransactionMember instance has no attribute 'ver'
yumdownloader with --resolve fails with TransactionMember instance has no att...
Status: CLOSED DUPLICATE of bug 391791
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: yum-utils (Show other bugs)
5.3
All Linux
low Severity low
: rc
: ---
Assigned To: James Antill
James Antill
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-27 18:48 EST by Michael Gregg
Modified: 2014-08-05 07:18 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-27 22:32:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Michael Gregg 2008-02-27 18:48:12 EST
How reproducible:
always

Steps to Reproduce:
1. run yumdownloader with --resolve
See "actual results" for a example.  

Actual results:
root@ipadev]# yumdownloader --resolve ipa-server ipa-admintools
Loading "installonlyn" plugin
Loading "rhnplugin" plugin
rhel-x86_64-server-supple 100% |=========================| 1.2 kB    00:00     
rhel-x86_64-server-5      100% |=========================| 1.4 kB    00:00     
rhn-tools-rhel-x86_64-ser 100% |=========================| 1.2 kB    00:00     
rhel-x86_64-server-5-beta 100% |=========================| 1.2 kB    00:00     
rhel-x86_64-server-5-rhdi 100% |=========================| 1.2 kB    00:00     
rhel-x86_64-server-5-apps 100% |=========================| 1.2 kB    00:00     
Traceback (most recent call last):
  File "/usr/bin/yumdownloader", line 191, in ?
    main()
  File "/usr/bin/yumdownloader", line 159, in main
    if not pkg in toDownload:
  File "/usr/lib/python2.4/site-packages/yum/packages.py", line 191, in __eq__
    if comparePoEVR(self, other) == 0 and self.arch == other.arch and self.name
== other.name:
  File "/usr/lib/python2.4/site-packages/yum/packages.py", line 35, in comparePoEVR
    (e2, v2, r2) = (po2.epoch, po2.ver, po2.rel)
AttributeError: TransactionMember instance has no attribute 'ver'


Expected results:
It to download.

Additional info:
This action seems to work on fc7's yumdownloader. I cannot find a matching bug
over there.
Comment 1 James Antill 2008-02-27 22:32:59 EST

*** This bug has been marked as a duplicate of 391791 ***
Comment 2 Chandrasekar Kannan 2008-02-28 08:37:39 EST
workaround - 

Based on upstream code, as a temporary workaround use the below fix, 

In /usr/lib/python2.4/site-packages/yum/packages.py

(e1, v1, r1) = (po1.epoch, po1.ver, po1.rel)
(e2, v2, r2) = (po2.epoch, po2.ver, po2.rel)

change the above line to,

(e1, v1, r1) = (po1.epoch, po1.version, po1.release)
(e2, v2, r2) = (po2.epoch, po2.version, po2.release)

save the file, and execute

Note You need to log in before you can comment on or make changes to this bug.