Bug 435219 - anaconda can't handle URL with port
anaconda can't handle URL with port
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F9Beta
  Show dependency treegraph
 
Reported: 2008-02-27 21:05 EST by Chris Adams
Modified: 2008-03-14 11:52 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-14 11:52:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Adams 2008-02-27 21:05:10 EST
I'm trying to install from a HTTP server running on port 8080 (e.g.
http://server:8080/path/to/rawhide/), and it causes anaconda to segfault:

loader received SIGSEGV!  Backtrace:
/sbin/loader(loaderSegvHandler+0xa0)[0x804fb90]
[0x131400]
/lib/libc.so.6(strcmp+0x14)[0x499724]
/lib/libc.so.6[0x517f9e]
/lib/libc.so.6(tsearch+0x6f)[0x502aef]
/lib/libc.so.6(__nss_lookup_function+0x5e)[0x517bce]
/lib/libc.so.6(__nss_next2+0x51)[0x5187e1]
/lib/libc.so.6(gethostbyname_r+0x165)[0x51ecd5]
/lib/libc.so.6(gethostbyname+0xe6)[0x51e556]
/sbin/loader(urlinstStartTransfer+0x302)[0x80681b2]
/sbin/loader[0x8060c62]
/sbin/loader[0x8060e41]
/sbin/loader(mountUrlImage+0x1df)[0x806129f]
/sbin/loader(main+0xfde)[0x805118e]
/lib/libc.so.6(__libc_start_main+0xe6)[0x438516]
/sbin/loader[0x804ddb1]
install existed abnormally [1/1]

It is easy to reproduce with any regular (port 80) HTTP mirror, just use
http://server:80/path/to/rawhide/.
Comment 1 Chris Adams 2008-02-27 22:10:21 EST
Weird; I added some debugging to loader2/urls.c, and I can see it splitting on
the ":" okay.  The call is as it should be, gethostbyname("server") (without the
port).  The first time through urlinstStartTransfer (looking for updates.img)
works okay, but the second (looking for product.img) is when it crashes.
Comment 2 Jeremy Katz 2008-03-02 12:32:45 EST
Peter fixed something on Friday which could impact this, but we should
definitely make sure it's fixed for the beta
Comment 3 Jeremy Katz 2008-03-05 14:06:23 EST
Nope, still broken.  Moving to block beta (although I'm going to look at it here
in a few minutes)
Comment 4 Jeremy Katz 2008-03-05 14:31:25 EST
And fixed
Comment 5 Will Woods 2008-03-14 11:52:10 EDT
Works for me, at least with the naive test (http://host:80/path/to/tree).

I'm going to close the bug - Chris, please give it another shot and feel free to
reopen if it doesn't work for your setup.

Note You need to log in before you can comment on or make changes to this bug.