Bug 435230 - Clean up all HTML pages (Gateway, Org Tool, Phonebook, etc)
Clean up all HTML pages (Gateway, Org Tool, Phonebook, etc)
Status: CLOSED CURRENTRELEASE
Product: 389
Classification: Community
Component: UI - Gateway/Phonebook (Show other bugs)
1.1.0
All All
medium Severity medium
: ---
: ---
Assigned To: Rich Megginson
Viktor Ashirov
:
Depends On:
Blocks: 434912
  Show dependency treegraph
 
Reported: 2008-02-27 22:39 EST by Rich Megginson
Modified: 2015-12-07 12:15 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-07 12:15:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
first pass - mostly pb, some common C code used by dsgw too (49.26 KB, text/plain)
2008-03-06 17:02 EST, Rich Megginson
no flags Details
cvs commit log (18.15 KB, text/plain)
2008-03-20 12:13 EDT, Rich Megginson
no flags Details
cvs commit log (561 bytes, text/plain)
2008-04-01 16:11 EDT, Rich Megginson
no flags Details

  None (edit)
Description Rich Megginson 2008-02-27 22:39:41 EST
+++ This bug was initially created as a clone of Bug #211296 +++

Description of problem:
This bug is to track the effort to clean up all HTML pages (Admin Express, Org
Tool, Phonebook, DSGW, etc)

Version-Release number of selected component (if applicable):
N/A

How reproducible:
N/A

Steps to Reproduce:
1. Run all the html tests through browser that has the plugin HTML Validator enabled
2. Append any error or key warning found to this bug report

-- Additional comment from ckannan@redhat.com on 2007-07-25 14:47 EST --
DS7.2 is not a valid milestone anymore. Anything thats set to DS7.2 should be
set to DS8.0. Will make further changes per bug council on 07/24/2007, after this.

-- Additional comment from ckannan@redhat.com on 2007-10-18 02:07 EST --
setting target DS8.1
Comment 1 Rich Megginson 2008-03-06 17:02:59 EST
Created attachment 297112 [details]
first pass - mostly pb, some common C code used by dsgw too

Resolves: bug 435230
Description: Clean up all HTML pages (Gateway, Org Tool, Phonebook, etc)
Fix Description: This is just the first pass.  I focused mainly on the
phonebook pages, but the C code fixes will apply to dsgw too.
The goal is to make the pages clean with HTML Tidy running in Firefox 2.
Most of the template pages had to change because they had comments like
this:
<!-- ----- comment -----
HTML 4.01 does not like this - no sequence of -- or more dashes in a comment.
The other major change was the use of &amp; instead of just a single & in
URLs for href and img src links.  However, javascript does not like the
encoded entities, so I had to add some code to make sure we use the
unencoded form in javascript, so I added another option called "entities"
to the html template code, and added a function that will convert
encoded entities to their raw form in place.
I'm also adding some debugging shell scripts that can be used to debug
CGI programs.
Platforms tested: RHEL5 x86_64
Flag day: Yes - autotool file changes.
Doc: none yet
Comment 2 Rich Megginson 2008-03-20 12:13:00 EDT
Created attachment 298710 [details]
cvs commit log

Fix Description: This is the second pass.  I focused mainly on the
dsgw pages.  Some of the fixes will apply to phonebook too.
I also moved the cgi bin directory to dsgw-cgi-bin - needs to be completely
separate from the admin server cgi bin directory.  There are changes to
dsgw-httpd.conf to reflect this as well as changes to other files.
The dsgw uses a path of dsgwcmd, instead of using cgi-bin directly.  This
is mapped in the dsgw-httpd.conf.
One problem that still remains - HTML Tidy does not like frames and framesets.
The only workaround suggested is to rewrite them using divs.  I'm not really
up to the task right now.
Platforms tested: RHEL5 x86_64
Flag day: Yes - autotool file changes.
Doc: none yet
Comment 3 Rich Megginson 2008-04-01 16:11:01 EDT
Created attachment 299961 [details]
cvs commit log

Fix Description: This is the third pass, fixing the orgchart.
Nothing really major, just fixing mostly table, tr, td, and img attributes. 
Tried to be a little smarter about when to actually create table rows - html
tidy does not like empty table rows.
Platforms tested: RHEL5 x86_64
Flag day: no
Doc: none yet
Comment 5 Anh Nguyen 2008-06-23 16:54:40 EDT
(In reply to comment #0)
> +++ This bug was initially created as a clone of Bug #211296 +++
> 
> Description of problem:
> This bug is to track the effort to clean up all HTML pages (Admin Express, Org
> Tool, Phonebook, DSGW, etc)
> 
> Version-Release number of selected component (if applicable):
> N/A
> 
> How reproducible:
> N/A
> 
> Steps to Reproduce:
> 1. Run all the html tests through browser that has the plugin HTML Validator
enabled
Rich, which html tests are you referring to? 
I am trying to verify this bug.
Anh.
> 2. Append any error or key warning found to this bug report
> 
> -- Additional comment from ckannan@redhat.com on 2007-07-25 14:47 EST --
> DS7.2 is not a valid milestone anymore. Anything thats set to DS7.2 should be
> set to DS8.0. Will make further changes per bug council on 07/24/2007, after this.
> 
> -- Additional comment from ckannan@redhat.com on 2007-10-18 02:07 EST --
> setting target DS8.1

Comment 6 Rich Megginson 2008-06-23 17:14:45 EDT
By "html tests" I mean the regular phonebook/gateway tests.  Just run those
tests with the HTML Tidy plugin active in Firefox and see if it reports any errors.
Comment 7 Anh Nguyen 2008-06-27 12:31:52 EDT
Install validator 0.7. Execute a number of operations. No errors were produced
by the Validator. Marking this bug VERIFIED.

Note You need to log in before you can comment on or make changes to this bug.