Bug 435249 - Bringing up bonding in balance-alb mode in RHEL 5.1 shows call traces in dmesg
Bringing up bonding in balance-alb mode in RHEL 5.1 shows call traces in dmesg
Status: CLOSED DUPLICATE of bug 251902
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.1
x86_64 Linux
low Severity high
: rc
: ---
Assigned To: Andy Gospodarek
Martin Jenner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-28 04:10 EST by Narendra K
Modified: 2014-06-29 18:59 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-10 13:25:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg output (38.55 KB, patch)
2008-02-28 04:10 EST, Narendra K
no flags Details | Diff

  None (edit)
Description Narendra K 2008-02-28 04:10:12 EST
Description of problem:

In RHEL 5.1 bringing up bond in balance-alb mode shows call traces in dmesg. I 
am reopening the bug "Bugzilla Bug 210577: BUG: bringing up balanced-alb mode 
bond network interface" (https://bugzilla.redhat.com/show_bug.cgi?id=210577).


Version-Release number of selected component (if applicable):

RHEL 5.1 kernel version: 2.6.18-53.el5
initscripts-8.45.17.EL-1

bonding driver version: 3.1.2
tg3 drive version: 3.83

How reproducible:

Always

Steps to Reproduce:

1. Configure a bond in balance-alb mode 

 ifcfg-bond0

   DEVICE=bond0
   ONBOOT=yes
   BOOTPROTO=dhcp
   TYPE=Bonding
   USERCTL=no

 ifcfg-eth2

 # Broadcom Corporation NetXtreme BCM5704 Gigabit Ethernet
 DEVICE=eth2
 BOOTPROTO=none
 HWADDR=00:0F:1F:FF:D2:CC
 ONBOOT=yes
 MASTER=bond0
 SLAVE=yes

 ifcfg-eth3

  # Broadcom Corporation NetXtreme BCM5704 Gigabit Ethernet
  DEVICE=eth3
  BOOTPROTO=none
  HWADDR=00:0F:1F:FF:D2:CD
  ONBOOT=yes
  MASTER=bond0
  SLAVE=yes

 /etc/modprobe.conf

  alias eth0 tg3
  alias eth1 tg3
  alias eth2 tg3
  alias eth3 tg3
  alias bond0 bonding
  options bond0 mode=balance-alb miimon=100

2. Restart the network with /etc/init.d/network restart and observer dmesg.
  
Actual results:
Dmesg shows call traces.

Expected results:
There should be no call traces when bonding is started.

Additional info: 
1. This bug opened in relation to  "Bugzilla Bug 210577: BUG: bringing up   
balanced-alb mode bond network interface" 
(https://bugzilla.redhat.com/show_bug.cgi?id=210577).
2. I have attached the dmesg output to this report.
Comment 1 Narendra K 2008-02-28 04:10:12 EST
Created attachment 296174 [details]
dmesg output
Comment 2 Andy Gospodarek 2008-03-10 13:25:33 EDT
A patch was included for bug 251902 that should resolve this issue.  The bonding
driver was updated for 5.2 and this issue is resolved.  

Please try the latest RHEL5.2 Beta Candidate or my test kernels

http://people.redhat.com/agospoda/#rhel5

and re-open this bug if you still find problems.

Thanks.

*** This bug has been marked as a duplicate of 251902 ***

Note You need to log in before you can comment on or make changes to this bug.