Bug 435252 - Discrepancy between df and quota commands in Red Hat Enterprise Linux ES 4 Update 3
Discrepancy between df and quota commands in Red Hat Enterprise Linux ES 4 Up...
Status: CLOSED DUPLICATE of bug 435108
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: quota (Show other bugs)
4.3
All Linux
low Severity urgent
: rc
: ---
Assigned To: Ondrej Vasik
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-28 05:20 EST by Balaji.S
Modified: 2008-03-04 11:40 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-04 11:40:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Balaji.S 2008-02-28 05:20:23 EST
Description of problem:
There is some discrepancy between what quota reports and what du reports

-bash-3.00$ cat /etc/redhat-release
Red Hat Enterprise Linux ES release 4 (Nahant Update 3)

-bash-3.00$ pwd
/home/corview

-bash-3.00$ df .
Filesystem           1K-blocks      Used Available Use% Mounted on
/dev/mapper/vgroot-LogVol01
                     10095152    586932   8995404   7% /home

-bash-3.00$ du -sh .
19M     .

-bash-3.00$ quota
Disk quotas for user corview (uid 934):
    Filesystem  blocks   quota   limit   grace   files   quota
limit   grace
/dev/mapper/vgroot-LogVol01
                968480* 900000 1000000    none     268       0       0


As shown above du says only 19MB is occupied by user corview( No big
files of corview are present in /tmp/ or /var/ )
But quota says 968480 out of  1000000   is used.



-bash-3.00$ id
uid=934(corview) gid=934(corview) groups=19(floppy),934(corview),935(admin)
-bash-3.00$ grep 934 /etc/passwd
corview:x:934:934::/home/corview:/bin/bash
nbiperf:x:946:934::/home/nbiperf:/bin/bash
nbibill:x:947:934::/home/nbibill:/bin/bash
rilbill:x:948:934::/home/rilbill:/bin/bash

So, no other user with id 934. and data in other users who are in
corview group is also very small.

lsof hasnt revealed any thing.

How do I know which file(s) is(are) eatig so much.?

I found a peculiar problem
-bash-3.00$ pwd
/home/corview
-bash-3.00$ ls -l
total 20
drwxrwxr-x  2 corview admin   4096 Nov 15 12:53 as
-rw-r--r--  1 corview corview    0 Feb  5 15:50 b
drwxr-xr-x  6 corview corview 4096 Nov 14 22:49 log
drwxr-xr-x  3 corview corview 4096 Nov 14 22:49 print
drwxr-xr-x  4 root    root    4096 Nov 14 22:48 replicatedfiles
drwx------  4 corview corview 4096 Nov 14 22:49 ricEMS
-bash-3.00$ find . -uid 934 -exec ls  -l "{}" ";"|nl

   38  -rwx------  1 corview corview 258959 Apr 27  2006 jta25b.jar
   39  -rwx------  1 corview corview     40 Feb  5  2007 Module.txt
   40  -rwx------  1 corview corview    164 Feb  5  2007 temp1.txt
   41  -rwx------  1 corview corview    249 Feb  6  2007 temp2.txt
   42  -rwx------  1 corview corview     93 Feb  6  2007 temp3.txt
   43  -rwx------  1 corview corview 249 Feb  6  2007
./ricEMS/corView/resource/con
fig/Profile/WorkingDirectory/temp2.txt
   44  -rwx------  1 corview corview 392 Feb  5  2007
./ricEMS/corView/resource/con
fig/Profile/WorkingDirectory/flt-http-deny-ruleid.txt
   45  -rwx------  1 corview corview 41 May 23  2007
./ricEMS/corView/resource/conf
ig/Profile/WorkingDirectory/BBGL_Enable.txt
   46  -rwx------  1 corview corview 26 May 23  2007
./ricEMS/corView/resource/conf
ig/Profile/WorkingDirectory/Adsl_Selt_Disconnect.txt
   47  -rwx------  1 corview corview 39 May 23  2007
./ricEMS/corView/resource/conf
ig/Profile/WorkingDirectory/Adsl_Selt_Connect.txt
   48  -rwx------  1 corview corview 40 Feb  5  2007
./ricEMS/corView/resource/conf
ig/Profile/WorkingDirectory/Module.txt
   49  -rwx------  1 corview corview 164 Feb  5  2007
./ricEMS/corView/resource/con
fig/Profile/WorkingDirectory/temp1.txt
   50  -rwx------  1 corview corview 258959 Apr 27  2006
./ricEMS/corView/resource/
config/Profile/WorkingDirectory/jta25b.jar
   51  -rwx------  1 corview corview 245 Feb  5  2007
./ricEMS/corView/resource/con
fig/Profile/WorkingDirectory/flt-arp-rep-srcip-deny-ruleid.txt

As we see some files show up twice in find.
For e.g, jta25b.jar is shown in line 50 (actual place) and in line 38
(bogus)

-bash-3.00$ pwd
/home/corview
-bash-3.00$ find . -name jta25b.jar
./ricEMS/corView/resource/config/Profile/WorkingDirectory/jta25b.jar
-bash-3.00$

How is this?

TIA 

Version-Release number of selected component (if applicable):
Red Hat Enterprise Linux ES release 4 (Nahant Update 3)

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Ondrej Vasik 2008-03-04 11:40:26 EST

*** This bug has been marked as a duplicate of 435108 ***

Note You need to log in before you can comment on or make changes to this bug.