Bug 435266 - Do not see /dev/ttyUSB* files - Cannot syn USB Palm Pilot
Do not see /dev/ttyUSB* files - Cannot syn USB Palm Pilot
Status: CLOSED DUPLICATE of bug 280251
Product: Fedora
Classification: Fedora
Component: usbutils (Show other bugs)
8
All Linux
low Severity high
: ---
: ---
Assigned To: Jiri Moskovcak
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-28 08:16 EST by John Curcio
Modified: 2015-02-01 17:48 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-11 07:38:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
udevinfo --export-db (12.37 KB, text/plain)
2008-03-25 07:54 EDT, John Curcio
no flags Details
Output of lshal (124.08 KB, text/plain)
2008-03-25 07:55 EDT, John Curcio
no flags Details
Dmesg, lshal and udevinfo output (180.91 KB, application/octet-stream)
2008-03-26 07:39 EDT, John Curcio
no flags Details

  None (edit)
Description John Curcio 2008-02-28 08:16:21 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.12) Gecko/20080208 Fedora/2.0.0.12-1.fc8 Firefox/2.0.0.12

Description of problem:
Suddenly I no longer can see a /dev/ttyUSB* files when I attempt to sync my USB-connected Palm Pilot. I see new /dev/usbdev* files (which seem to change on every sync attempt) and /var/log/messages reports seeing the Palm but no ttyUSB* files are to be found. 

Version-Release number of selected component (if applicable):
usbutils-0.71-2.1, udev-118-1.fc8

How reproducible:
Always


Steps to Reproduce:
1.Attempt to sync USB-connected Palm Pilot
2.
3.

Actual Results:
ls -sl /dev/ttyUSB* show no such files

Expected Results:
/dev/ttyUSB[01] visible

Additional info:
Without this file (or a substitute) I cannot use my Palm Pilot which is a (very!) mission-critical app for me! This is a huge problem! I have attempted this in KDE and Gnome and attempted a reboot, just in case ... but all with the same result. Did I miss something or is this a new bug?
Comment 1 Jiri Moskovcak 2008-03-18 06:23:11 EDT
Could you post output from lshal and udevinfo?
Comment 2 John Curcio 2008-03-25 07:54:29 EDT
Created attachment 299009 [details]
udevinfo --export-db

Not sure which modifiers you wanted for the udevinfo command so here is the
output of export-db. Please let me know if you would like any additonal
information.

Thanks,
John C
Comment 3 John Curcio 2008-03-25 07:55:43 EDT
Created attachment 299010 [details]
Output of lshal

Sorry it took so long to get back to you ... I was out in Denver for a week.
Here is the output generated by the lshal command. Please let me know if I can
be of any further assitance.

Thanks,
John C
Comment 4 Jiri Moskovcak 2008-03-25 09:22:20 EDT
Did you create these attachments with palm connected? Can you please post 
output of $ dmesg | tail right after you connect your palm to usb.

Jirka
Comment 5 John Curcio 2008-03-26 07:39:50 EDT
Created attachment 299131 [details]
Dmesg, lshal and udevinfo output

Ah-ha! ... you didn't mention having the Palm hooked up  :-) Here (in one file)
I'm attaching the output of dmesg, lshal and udev --export-db with the Palm on
it's USB sync station.

Thanks,
John C
Comment 6 Jiri Moskovcak 2008-04-11 06:19:50 EDT
Sorry for the delay, but I didn't have a palm. anyway, I just got one and find 
a possible solution:
1. log as root
2. $ modprobe visor   (module responsible for ttyUSB#)
2. try to sync your palm
maybe you'll have to do $ ln -s /dev/ttyUSB0 /dev/pilot to make jpilot work.
udev should take care of all of this, but I'm not sure and will try to find 
some more elegant solution, this is just a quick fix to make it work..

Jirka
Comment 7 Jiri Moskovcak 2008-04-11 07:20:50 EDT
So, there seems to be a bug in hal and halinfo which should be fixed soon, in 
the meantime you can use this solution:
1. create an udev rule (a file): /etc/udev/rules.d/10-visor.rules contaning:
BUS=="usb", SYSFS{product}=="Palm Handheld*", KERNEL=="ttyUSB0", SYMLINK
+="pilot"
2. edit the file /etc/modprobe.d/blacklist-visor - comment the line visor:
#visor
3. restart computer (or just udev) and jpilot should work again.
But I've been told there is a bug in visor module so use it on your own 
responsibility and as soon as the update for hal is released stop using this.

Hope this help,
Jirka
Comment 8 Jiri Moskovcak 2008-04-11 07:22:56 EDT
One more thing - the ttyUSB# nodes will show up after you press the hotsync 
button.
Comment 9 Jiri Moskovcak 2008-04-11 07:38:45 EDT

*** This bug has been marked as a duplicate of 280251 ***

Note You need to log in before you can comment on or make changes to this bug.