Bug 435271 - RuntimeError: Error running lvm: Cannot allocate memory
RuntimeError: Error running lvm: Cannot allocate memory
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: anaconda (Show other bugs)
5.2
All Linux
high Severity low
: rc
: ---
Assigned To: Anaconda Maintenance Team
:
Depends On:
Blocks: RHEL5u2_relnotes RHEL5u3_relnotes
  Show dependency treegraph
 
Reported: 2008-02-28 08:54 EST by Alexander Todorov
Modified: 2010-10-22 18:52 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
(ia64) If your system only has 512MB of RAM, attempting to install Red Hat Enterprise Linux 5.3 may fail. To prevent this, perform a base installation first and install all other packages after the installation finishes.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-11 14:44:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda.log from the installed system (428.87 KB, text/plain)
2008-02-28 08:54 EST, Alexander Todorov
no flags Details
anacdump.txt (651.32 KB, text/plain)
2008-04-09 10:51 EDT, Alexander Todorov
no flags Details

  None (edit)
Description Alexander Todorov 2008-02-28 08:54:02 EST
Description of problem:
Anaconda traceback during DVD install on a Xen guest

Version-Release number of selected component (if applicable):
anaconda-11.1.2.103-1.ia64.rpm
RHEL5.2-Server-20080225.2

How reproducible:
100%

Steps to Reproduce:
1. Boot from DVD
2. Select default partitioning
3. Select all packages
  
Actual results:
Anaconda traceback. Installation is aborted

Expected results:
Installation proceeds.

Additional info:
The installation is performed by creating new Xen hvm guest on ia64.
Comment 1 Alexander Todorov 2008-02-28 08:54:02 EST
Created attachment 296209 [details]
anaconda.log from the installed system
Comment 3 Alexander Todorov 2008-02-28 08:55:48 EST
13:42:51 CRITICAL: Traceback (most recent call first):
  File "/usr/lib/anaconda/iutil.py", line 50, in execWithRedirect
    raise RuntimeError, "Error running " + command + ": " + msg
  File "/usr/lib/anaconda/lvm.py", line 84, in vgactivate
    stderr = output, searchPath = 1)
  File "/usr/lib/anaconda/partitions.py", line 1360, in doMetaDeletes
    lvm.vgactivate()
  File "/usr/lib/anaconda/packages.py", line 144, in turnOnFilesystems
    anaconda.id.partitions.doMetaDeletes(anaconda.id.diskset)
  File "/usr/lib/anaconda/dispatch.py", line 201, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 124, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/gui.py", line 1018, in nextClicked
    self.anaconda.dispatch.gotoNext()
  File "/usr/lib/anaconda/iw/progress_gui.py", line 243, in renderCallback
    self.intf.icw.nextClicked()
  File "/usr/lib/anaconda/gui.py", line 1045, in handleRenderCallback
    self.currentWindow.renderCallback()
RuntimeError: Error running lvm: Cannot allocate memory
Comment 4 Alexander Todorov 2008-02-28 08:57:06 EST
HVM guest is started with 512 MB of memory, newly created disk image.
The same configuration works when booting with boot.iso and http install method.
Comment 8 Alexander Todorov 2008-03-31 08:31:39 EDT
Additional info to match summary:
anaconda needs to show a nice dialog to the user informing them that available
memory is not enough but not produce a runtime traceback.
This needs to match system requirements for the related release and chosen
install methods.
Comment 9 Jeremy Katz 2008-03-31 12:02:22 EDT
How much memory does the machine have?  The minimums should be reasonable across
all platforms.  And usually, the bug is a red herring for something else (worse)
going wrong.
Comment 10 Alexander Todorov 2008-03-31 12:11:09 EDT
Jeremy,
the original bug was filed against a Xen HVM guest with 512 MB of memory (and no
higher limit IIRC).
Comment 11 Jeremy Katz 2008-03-31 12:56:28 EDT
512 megs should be enough -- if not, then that's a bug which should be fixed. 
Not papered over with a dialog.
Comment 12 Alexander Todorov 2008-04-01 07:46:44 EDT
Steps to reproduce:
1) boot from DVD (ia64) (xen hvm, 512 MB memory)
2) start VNC install
3) choose default install
4) select "Customize packages"
5) choose all package groups

When anaconda tries to format partitions the traceback happens.
Comment 13 Alexander Todorov 2008-04-01 09:26:52 EDT
Tested with RHEL 5.1 GA under the same memory limitations and steps to
reproduce. Can't see the traceback.
Comment 14 Alexander Todorov 2008-04-09 10:47:19 EDT
Also seeing this with 5.2 snap #4 steps to reproduce:
1) Create a new Xen HVM guest (use single file as storage - 15GB, 4GB memory)
2) Use kickstart that contains @everything
3) Choose: remove all partitions and create default layout

Attaching debug info shortly.
Comment 15 Alexander Todorov 2008-04-09 10:51:42 EDT
Created attachment 301820 [details]
anacdump.txt
Comment 16 Alexander Todorov 2008-04-10 08:40:26 EDT
Trying with same disk image (Xen) but without using lvm I had the same error.
Anaconda is running lvm to detect and delete previous partitions before creating
the new ones, right?
Comment 17 Alexander Todorov 2008-04-10 09:00:46 EDT
Trying with newly created disk image and using native partitions I see the same
error.
Comment 18 Alexander Todorov 2008-04-10 11:28:38 EDT
More info on this one:
It appeared that HVM guests can't bolloon memory as PV ones (I didn't know that).
So in all tests above the guest has been running with the start up memmory
allocation (512MB). Bumping that up to 2GB worked around the problem.

The faulty component to blame here is most probably yum. Python objects on 64bit
arches use 4 times more memory than on 32bit. Before the error happens yum is
resolving all deps.
Comment 21 Alexander Todorov 2008-04-11 05:47:03 EDT
After talking to ddumas today we've decided to release note this issue:

<text>
When installing all packages available for Red Hat Enterprise Linux 5.2 on ia64
the installation may fail on machines with 512 MB of memory. To work around this
perform a base or default install and then install all additional packages.
</text>

Brock, 
what flags we need to get this in the 5.2 release notes?
Comment 22 Brock Organ 2008-04-11 11:08:24 EDT
After running the tests on bare metal for ia64, it looks like 6 of the 10
installs using 512 Mb (via mem=512M cmdline parameter) fail, while 4 succeed.  

ddomingo is cc'd on this bug, and I'll ping him about getting this for 5.2 ...

Comment 23 Don Domingo 2008-04-13 19:05:46 EDT
thanks Alex, Brock; adding to RHEL5.2 release notes under "Installation-Related
Notes":

<quote>
(ia64) If your system has 512MB of RAM, attempting to install Red Hat Enterprise
Linux 5.2 may fail. To prevent this, perform a base installation first and
install all other packages after the installation finishes.
</quote>

please advise (before April 15) if any further revisions are required. also,
FYR, the updated RHEL5.2 release notes mockup can be viewed here:
http://intranet.corp.redhat.com/ic/intranet/RHEL5u2relnotesmockup.html
Comment 24 Brock Organ 2008-04-14 15:38:06 EDT
Thanks, Don!

verified entry at:

http://intranet.corp.redhat.com/ic/intranet/RHEL5u2relnotesmockup.html

will move to VERIFIED when we see this version in the compose tree ...
Comment 27 Chris Lumens 2008-06-10 17:32:11 EDT
Is this only reproducable on 64-bit machines doing Everything installs?
Comment 28 Alexander Todorov 2008-06-11 07:55:24 EDT
Looks like it's ia64 only. I wasn't able to reproduce on other 64bit arches
Comment 29 Chris Lumens 2008-06-11 14:25:21 EDT
This is only affecting one platform and I haven't seen any evidence that it
happens outside of Everything (or similarly gigantic) package sets.  Also it's
likely this is not an anaconda bug, but instead is a bug in yum memory usage or
Python's 64 bit object size.  I doubt there's really anything we can do in
anaconda.  NAKing for those reasons.
Comment 30 RHEL Product and Program Management 2008-06-11 14:44:25 EDT
Development Management has reviewed and declined this request.  You may appeal
this decision by reopening this request. 
Comment 31 Ryan Lerch 2008-08-05 21:13:29 EDT
This bug has been added to the the RHEL 5.3 Release Notes (as quoted in the release note field of this bug).

If any revisions are required, please set the "requires_release_notes" flag to "?" and edit the Release Notes field accordingly.
Comment 32 Ryan Lerch 2008-08-05 21:13:29 EDT
Added New Release Notes Contents.

Note You need to log in before you can comment on or make changes to this bug.