Bug 435316 - copy to/from samba share fails with "The specified network name is no longer available"
copy to/from samba share fails with "The specified network name is no longer ...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: samba (Show other bugs)
5.1
All Linux
low Severity high
: rc
: ---
Assigned To: Samba Maint Team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-28 12:37 EST by Paul Bijnens
Modified: 2008-05-21 13:26 EDT (History)
2 users (show)

See Also:
Fixed In Version: RHBA-2008-0372
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-21 13:26:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
simple log of the bug detail level - (12.54 KB, text/plain)
2008-05-01 11:40 EDT, leonard kroll
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Samba Project 4763 None None None Never

  None (edit)
Description Paul Bijnens 2008-02-28 12:37:44 EST
Description of problem:

A copy from or to a samba share frequently fails with error:
"The specified network name is no longer available"

Filesize is correct, but is corrupt (ends in several megabyte ascii-nul).

Around the same time the event log in the Windows machine says:
NetBT Event ID 4322:
NetBT could not process a request, because at least one
OutOfResources-Exception occurred in the last hour".

Network tracing showed it is the Windows PC that sends a TCP RST
packet to the server, breaking the connection.

Version-Release number of selected component (if applicable):
samba-3.0.25b-1.el5_1.4


How reproducible:

We can only reproduce it on our faster servers (Xeon dual core) with 
gigabit ethernet, and older PC clients (WinXP, 4 years old),
which are connected with 100mbit.

The error has more chance of occurring when you copy some other small
files into the same directory while a large file copy is busy.

The error has *less* chance of occurring when modifying the socket
options in smb.conf, and settings the socket buffers to 8K or 4K.
(I believe the default buffersize is 65K?).


Steps to Reproduce:
1.  Copy a large file to the share (e.g. 10 mB).
2.  
3.
  
Actual results:

Error msg on Windows PC. Samba logs contains an error
followed by a reconnect from the client PC to the share:

[2008/02/28 10:02:03, 0] lib/util_sock.c:read_data(534)
  read_data: read failure for 4 bytes to client 10.32.1.143. Error = Connection
reset by peer
[2008/02/28 10:02:04, 0] lib/util_sock.c:write_data(562)
  write_data: write failure in writing to client 10.32.1.143. Error Broken pipe
[2008/02/28 10:02:04, 0] lib/util_sock.c:send_smb(769)
  Error writing 75 bytes to client. -1. (Broken pipe)
[2008/02/28 10:02:04, 0] lib/util_sock.c:write_data(562)
  write_data: write failure in writing to client 10.32.1.143. Error Connection
reset by peer
[2008/02/28 10:02:04, 0] lib/util_sock.c:send_smb(769)
  Error writing 4 bytes to client. -1. (Connection reset by peer)
[2008/02/28 10:02:10, 1] smbd/service.c:make_connection_snum(1033)
  ajaccio (10.32.1.143) connect to service xls initially as user sophiep
(uid=1163, gid=10) (pid 10900)


Expected results:


Additional info:

In a test setup I applied the patch found at:
https://bugzilla.samba.org/show_bug.cgi?id=4763
and I could not reproduce the error anymore.  
That patch probably can fix it.
Comment 5 dijuremo 2008-04-07 12:13:14 EDT
I had a similar situation but in my case it was only copying files from the
samba server to a different folder on the same server. So from a windows machine
I would select a file, then copy it, go into a sub-folder then paste and I would
get the error.

I seem to have fixed my problem by adding the localhost subnet to hosts.allow in
smb.conf and restarting samba (reloading the configuration file should to as well).

hosts allow = subnet1. subnet2. 127.0.0.
hosts deny = 0.0.0.0/24

Not sure if this will help you, but it is something you may want to try.
Comment 6 dijuremo 2008-04-07 13:31:11 EDT
arggg... cannot type right.... my hosts deny entry had a typo, it should be:

hosts deny = 0.0.0.0/0
Comment 8 Paul Bijnens 2008-04-17 04:50:02 EDT
OK, I added the hosts allow and hosts deny to our smb.conf, and watched for any
impact for more than 1 week.
I can only conclude that it does not matter.  One machine without the patch still
had the problem at least twice.  One machine with patched samba does not show
the problem (even without the hosts deny lines in smb.conf).
Comment 9 leonard kroll 2008-05-01 11:40:38 EDT
Created attachment 304313 [details]
simple log of the bug detail level -

If you need a more detailed log, please let me know.
I will set the log level and debug level at whatever setting you need.
Comment 10 Will Tatam 2008-05-20 10:41:05 EDT
Looks like this relates to https://bugzilla.samba.org/show_bug.cgi?id=4763
Comment 11 errata-xmlrpc 2008-05-21 13:26:57 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0372.html

Note You need to log in before you can comment on or make changes to this bug.