Bug 435317 - pidgin doesn't notice network changes
pidgin doesn't notice network changes
Status: CLOSED DUPLICATE of bug 333351
Product: Fedora
Classification: Fedora
Component: pidgin (Show other bugs)
8
All Linux
medium Severity medium
: ---
: ---
Assigned To: Warren Togami
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-28 12:41 EST by Jason Merrill
Modified: 2008-03-11 10:59 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-11 10:59:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jason Merrill 2008-02-28 12:41:16 EST
Description of problem:

When I suspend and resume my laptop, or move between networks, the network
connection changes and Pidgin is no longer connected to the servers.  However,
it doesn't notice this until a significant amount of time has gone by, so I
frequently lose incoming IMs during the period that Pidgin incorrectly thinks it
is connected.  To work around this I need to manually disconnect and reconnect
Pidgin.

Version-Release number of selected component (if applicable):

pidgin-2.3.1-1.fc8

How reproducible:

Steps to Reproduce:
1. Open Pidgin, connect to server
2. Move from wired to wireless network
3. Have someone send me a message
  
Actual results:

Message is lost.

Expected results:

Pidgin notices the network connection drop and refreshes server connections when
the network comes back.

Additional info:

This bug has been upstream for almost a year with no action:

http://developer.pidgin.im/ticket/181
Comment 1 Stu Tomlinson 2008-03-11 10:59:50 EDT

*** This bug has been marked as a duplicate of 333351 ***

Note You need to log in before you can comment on or make changes to this bug.