Bug 435376 - radeonhd vs Dell 2001FP @1600x1200 w/DVI
radeonhd vs Dell 2001FP @1600x1200 w/DVI
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-radeonhd (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Hans Ulrich Niedermann
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-28 16:20 EST by Jim Meyering
Modified: 2013-03-13 16:41 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-14 14:17:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xorg.0.log (108.44 KB, text/plain)
2008-02-28 16:20 EST, Jim Meyering
no flags Details
xorg.0.log, per above (30.82 KB, text/plain)
2008-02-29 11:21 EST, Jim Meyering
no flags Details

  None (edit)
Description Jim Meyering 2008-02-28 16:20:43 EST
Description of problem: a DVI-connected Dell 2001FP monitor works at lower
resolution, but cannot do 1600x1200 with a Radeon HD 2400PRO (Asus
EAH2400PRO/HTP/256M).  I've tried all of radeonhd, radeon, ati drivers in
xorg.conf, to no avail.  This URL might be relevant: 
http://suif.stanford.edu/~csapuntz/rv280-linux-dvi.html -- it shows someone
having what looks like a similar problem (162MHz > max of 160) and fixing it in
the radeon driver of many years ago.

Version-Release number of selected component (if applicable):
xorg-x11-drv-radeonhd-1.1.0-0.6.20080216git.fc9.x86_64
xorg-x11-drv-ati-6.8.0-2.fc9.x86_64
xorg-x11-server-devel-1.4.99.1-0.23.20080222.fc9.x86_64

How reproducible: always


Steps to Reproduce:
1.log in without gdm/xdm/etc.
2.run "startx"
3.

Actual results:
screen goes black, and this flashes at irregular intervals:

  2:DVI-D
  Can not display this mode

[BTW, that also happens at boot time for about a minute]

Expected results:
I'd get a 1600x1200 display.

Additional info:
worked ok at 14x10

Xorg.0.log to follow
Comment 1 Jim Meyering 2008-02-28 16:20:43 EST
Created attachment 296264 [details]
xorg.0.log
Comment 2 Hans Ulrich Niedermann 2008-02-29 10:57:10 EST
The xorg.0.log file suggests that you are using the radeon driver (package
xorg-x11-drv-ati), not the radeonhd driver (package xorg-x11-drv-radeonhd).

radeonhd should be able to cope with your situation, at the very least with
'Option "ForceReduced" "on"' in the 'Section "Device"'.

Did you generate the xorg.0.log file at the wrong time or did you file this bug
against the wrong package?
Comment 3 Jim Meyering 2008-02-29 11:19:43 EST
Hi Hans,

Thanks for the feedback.

I get the same results (same thing displayed on screen) regardless of whether I
use ati, radeon or radeonhd.  Yesterday, Dave Airlie said attaching any of the
three xorg.0.log files would be ok.  In any case, I've just rerun startx using
xorg.conf as you suggest.  No change.  New xorg.0.log to follow.
Comment 4 Jim Meyering 2008-02-29 11:21:03 EST
Created attachment 296380 [details]
xorg.0.log, per above
Comment 5 Bug Zapper 2008-05-14 01:41:42 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 6 Bug Zapper 2009-06-09 19:38:55 EDT
This message is a reminder that Fedora 9 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 9.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '9'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 9's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 9 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 7 Bug Zapper 2009-07-14 14:17:59 EDT
Fedora 9 changed to end-of-life (EOL) status on 2009-07-10. Fedora 9 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.