Bug 435403 - getfacl issue dealling with symbol link
getfacl issue dealling with symbol link
Status: CLOSED DUPLICATE of bug 223840
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: acl (Show other bugs)
5.3
i386 Linux
low Severity medium
: rc
: ---
Assigned To: Jiri Moskovcak
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-28 22:08 EST by Bobi Jam
Modified: 2015-02-01 17:48 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-10 09:14:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bobi Jam 2008-02-28 22:08:09 EST
Description of problem:

getfacl (btw my getfacl version is 2.2.39, belongs to
acl-2.2.39-1.1) just literally find the link target with `pwd`+[symbol
content], regardless where the link file is located.


How reproducible:

Steps to Reproduce:
1. mkdir d; set an acl list for d.
2. mkdir d/d; set another different acl list for d/d.
3. create a symbol link d/l whose symbol content is 'd'.
4. getfacl --omit-header d/l 
  (during this procedure, don't chdir)
  
Actual results:
acl list of d/d

Expected results:
acl list of d
Comment 1 Jiri Moskovcak 2008-04-10 09:14:18 EDT
According to rhbz#223840 this is fixed in acl-2.2.39-2.1 and this package 
should be available in RHEL-5.1. Closing as duplicate.

*** This bug has been marked as a duplicate of 223840 ***

Note You need to log in before you can comment on or make changes to this bug.