Bug 435439 - xterm-232-1.fc8.rpm update causes segfault in xterm
xterm-232-1.fc8.rpm update causes segfault in xterm
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: xterm (Show other bugs)
8
i386 Linux
low Severity low
: ---
: ---
Assigned To: Miroslav Lichvar
Fedora Extras Quality Assurance
:
: 436897 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-29 06:12 EST by James Thorne
Modified: 2008-03-13 06:14 EDT (History)
1 user (show)

See Also:
Fixed In Version: 234-1.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-13 03:48:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
strace output for xterm-232-1.fc8 (68.00 KB, application/octet-stream)
2008-02-29 06:12 EST, James Thorne
no flags Details

  None (edit)
Description James Thorne 2008-02-29 06:12:54 EST
Description of problem:

Installing the latest update for xterm (232-1.fc8) causes xterm to seg fault.

Version-Release number of selected component (if applicable):

232-1.fc8

How reproducible:

Every time it's installed on both mine and my colleague's machines, either as
root or a normal user.

Steps to Reproduce:
1. Update xterm to 232-1.fc8:
# yum update xterm

2. Run xterm:
# xterm
Segmentation fault
  
Actual results:

Segmentation fault

Expected results:
xterm runs OK

Additional info:

Backing out to the previous version (229-2.fc8) fixes the problem:

# yum remove xterm
# yum install xterm-229-2.fc8
# xterm
(xterm runs OK)

$ uname -a
Linux hagrid 2.6.23.15-137.fc8 #1 SMP Sun Feb 10 17:48:34 EST 2008 i686 i686
i386 GNU/Linux
Comment 1 James Thorne 2008-02-29 06:12:54 EST
Created attachment 296327 [details]
strace output for xterm-232-1.fc8
Comment 2 Miroslav Lichvar 2008-02-29 06:34:55 EST
Can you please try xterm-233-1.fc9 from rawhide?

http://koji.fedoraproject.org/packages/xterm/233/1.fc9/i386/xterm-233-1.fc9.i386.rpm
Comment 3 James Thorne 2008-02-29 06:40:25 EST
The rawhide RPM works a treat.  Thanks.

I forgot to mention that we were forwarding X over SSH to cygwin X.  When I
found a colleague with a local gnome desktop, xterm worked OK displaying to his
desktop so maybe it's something to do with that.

Thanks for the pointer to the rawhide RPM.
Comment 4 Miroslav Lichvar 2008-02-29 06:48:08 EST
Ok, I'll prepare updates for F7 and F8.
Comment 5 Fedora Update System 2008-02-29 07:04:26 EST
xterm-233-1.fc7 has been submitted as an update for Fedora 7
Comment 6 Fedora Update System 2008-02-29 07:04:58 EST
xterm-233-1.fc8 has been submitted as an update for Fedora 8
Comment 7 James Thorne 2008-02-29 08:35:49 EST
Cool.  Thanks Miroslav.
Comment 8 Fedora Update System 2008-03-01 04:25:45 EST
xterm-233-1.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update xterm'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F7/FEDORA-2008-2130
Comment 9 Fedora Update System 2008-03-03 12:06:04 EST
xterm-234-1.fc8 has been submitted as an update for Fedora 8
Comment 10 Fedora Update System 2008-03-03 12:06:08 EST
xterm-234-1.fc7 has been submitted as an update for Fedora 7
Comment 11 Miroslav Lichvar 2008-03-11 11:53:11 EDT
*** Bug 436897 has been marked as a duplicate of this bug. ***
Comment 12 Fedora Update System 2008-03-13 03:46:33 EDT
xterm-234-1.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 13 Fedora Update System 2008-03-13 03:48:37 EDT
xterm-234-1.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 14 James Thorne 2008-03-13 06:14:45 EDT
Works fine.  Thanks for fixing it.

Note You need to log in before you can comment on or make changes to this bug.