Bug 435473 - powernow-k8: MP systems not supported by PSB BIOS structure
powernow-k8: MP systems not supported by PSB BIOS structure
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
8
All Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-29 11:09 EST by Nicolas Chauvet (kwizart)
Modified: 2008-02-29 16:50 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-29 15:31:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg output (27.34 KB, text/plain)
2008-02-29 11:12 EST, Nicolas Chauvet (kwizart)
no flags Details
cpuinfo for kwizatz workstation (1.26 KB, text/plain)
2008-02-29 11:13 EST, Nicolas Chauvet (kwizart)
no flags Details
dmidecode output for kwizatz workstation (13.38 KB, text/plain)
2008-02-29 11:13 EST, Nicolas Chauvet (kwizart)
no flags Details

  None (edit)
Description Nicolas Chauvet (kwizart) 2008-02-29 11:09:42 EST
Description of problem:
Since some undetermined kernel update. I have this message when booting.
Something went wrong with powernow-k8 that makes the cpuspeed daemon to fail to
work as usual. (the daemon cannot be started)

Version-Release number of selected component (if applicable):
The problem have been experienced with
[root@kwizatz F-7]# rpm -q kernel
kernel-2.6.23.15-137.fc8
kernel-2.6.24.2-7.fc8
kernel-2.6.23.14-115.fc8
kernel-2.6.24.3-13.fc8
I also tryed to downgrade cpuspeed, but it seems not be related to it. (at least
I thought it was working previsouly with an older kernel , I'm still searching
for lastest older kernel that works. )

How reproducible:
always

Steps to Reproduce:
[root@kwizatz ~]# service cpuspeed start
[root@kwizatz ~]# service cpuspeed status
cpuspeed is stopped
[root@kwizatz ~]# service cpuspeed stop
[root@kwizatz ~]#
  
Actual results: cpuspeed cannot be started, and no message tells it has failed
to load. It probably fails around this:
[root@kwizatz init.d]#cat /sys/devices/system/cpu/cpu0/cpufreq
cat: /sys/devices/system/cpu/cpu0/cpufreq: This file doesn't exist
[root@kwizatz init.d]# cat /sys/devices/system/cpu/cpu0/[tab]
cache/       crash_notes  topology/

Expected results: cpuspeed should be allowed to start If powernow-k8 isn't
failing to work.


Additional info:
since 2.6.24's kernels I also have this message:
pnpacpi: exceeded the max number of mem resources: 12

No bios updates are currently available for this workstation. (last is
V 1.D from 01/29/2007) 
MotherBoard is MSI K8N neo2 Platinum. (s939)

dmesg dmidecode and /proc/cpuinfo are comming soon.
Comment 1 Nicolas Chauvet (kwizart) 2008-02-29 11:12:40 EST
Created attachment 296375 [details]
dmesg output
Comment 2 Nicolas Chauvet (kwizart) 2008-02-29 11:13:23 EST
Created attachment 296377 [details]
cpuinfo for kwizatz workstation
Comment 3 Nicolas Chauvet (kwizart) 2008-02-29 11:13:58 EST
Created attachment 296378 [details]
dmidecode output for kwizatz workstation
Comment 4 Chuck Ebbert 2008-02-29 11:24:38 EST
The system BIOS doesn't support dual-core processors. There is nothing we can do
about that.
Comment 5 Dave Jones 2008-02-29 11:35:32 EST
but the initial report suggests that this worked once ?
This means ACPI has regressed, and we're falling back to the PSB.
Comment 6 Chuck Ebbert 2008-02-29 14:30:10 EST
(In reply to comment #5)
> but the initial report suggests that this worked once ?
> This means ACPI has regressed, and we're falling back to the PSB.
> 

Apparently it worked until the system was upgraded with a dual-core processor
(and the BIOS wasn't updated.)
Comment 7 Nicolas Chauvet (kwizart) 2008-02-29 15:04:48 EST
Apparently I have this problem since the F8 "gold" kernel
(kernel-2.6.23.1-42.fc8), and maybe earlier... I will try to re-install FC-6 or
F-7. 
On the other side I hope to have a newer bios from MSI but... well, I will see..
For now. I have the most current bios available, and indeed I have upgraded from
mono to dual-core processor.





Comment 8 Dave Jones 2008-02-29 15:31:45 EST
ah, in that case F6/F7 likely won't help either.  Sounds like the "powernow for
>1 cpu" acpi tables are missing entirely.  It's likely only a bios upgrade can
save you.
Comment 9 Nicolas Chauvet (kwizart) 2008-02-29 15:47:47 EST
OK the problem disappeared when i entered the bios and figured out that "cool &
quiet" was desactivated  - (I've also switched from S1 to S3).

Now I it can run cpuspeed:
[root@kwizatz ~]# service cpuspeed status
Frequency scaling enabled using ondemand governor

Sorry from this wrong report - I haven't thought the message could be linked to
an option that can be activated/desactivated from the bios.


Comment 10 Nicolas Chauvet (kwizart) 2008-02-29 16:50:05 EST
This might not be as easy as expected.

I've experienced a freeze (at least with kernel-2.6.24.3-13.fc8 ), when cool &
quiet is re-enabled. and I haven't experienced such freeze since much time. I
think I may have disabled C&Q because of that. Which may indicate a bios problem.

For now, and kernel-2.6.23.15-137.fc8, everything seems fine... let's see.


Note You need to log in before you can comment on or make changes to this bug.