Bug 435491 - RHEL4u6 clvmd - lvm commands hang and lvm commands are in 'S' state waiting on syscall connect() to finish
RHEL4u6 clvmd - lvm commands hang and lvm commands are in 'S' state waiting o...
Status: CLOSED ERRATA
Product: Red Hat Cluster Suite
Classification: Red Hat
Component: lvm2-cluster (Show other bugs)
4
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Christine Caulfield
Cluster QE
: Reopened
Depends On:
Blocks: 439384
  Show dependency treegraph
 
Reported: 2008-02-29 12:15 EST by Shane Bradley
Modified: 2010-01-11 23:07 EST (History)
9 users (show)

See Also:
Fixed In Version: RHBA-2008-0806
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-25 15:26:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
strace tgz file (48.96 KB, application/x-gzip)
2008-02-29 12:17 EST, Shane Bradley
no flags Details
backtrace of dlm connection stack trace (5.24 KB, text/plain)
2008-02-29 12:18 EST, Shane Bradley
no flags Details
device mapper data for machine 89 (24.15 KB, application/x-gzip)
2008-03-03 14:34 EST, Eduardo Damato
no flags Details
device mapper data for machine 91 (291.00 KB, application/x-tar)
2008-03-03 14:34 EST, Eduardo Damato
no flags Details
device mapper data for all nodes. (10.10 MB, application/x-tar)
2008-03-05 14:00 EST, Eduardo Damato
no flags Details
/proc/cluster for all nodes (111.24 KB, application/x-gzip)
2008-03-05 14:01 EST, Eduardo Damato
no flags Details
all logs /var/log/messages for all nodes (8.19 MB, application/x-tar)
2008-03-05 14:02 EST, Eduardo Damato
no flags Details

  None (edit)
Description Shane Bradley 2008-02-29 12:15:38 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.12) Gecko/20080208 Fedora/2.0.0.12-1.fc8 Firefox/2.0.0.12

Description of problem:
Clvmd appears to be hanging(RHEL4u6 x86_64). The lvm commands hang and
lvm commands are in 'S' state waiting on syscall connect() to finish.


../ps/ps-aux-su210091.txt:root     30930  0.0  0.0 62236 2052 ?        S    05:30   0:00 /usr/sbin/lvscan
../ps/ps-aux-su210091.txt:root     31068  0.0  0.0 62236 2052 ?        S    Feb27   0:00 /usr/sbin/lvscan
../ps/ps-aux-su210091.txt:root     31208  0.0  0.0 62236 2052 ?        S    01:37   0:00 /usr/sbin/lvscan
../ps/ps-aux-su210091.txt:root     31264  0.0  0.0 62236 2052 ?        S    16:25   0:00 /usr/sbin/lvscan
../ps/ps-aux-su210091.txt:root     31294  0.0  0.0 62236 2052 ?        S    10:29   0:00 /usr/sbin/lvscan

backtrace of the threads showing the dlm connections is in file gdb.txt that is uploaded.
Uploaded a file that contains straces of lvm commands is uploaded as well.


Version-Release number of selected component (if applicable):


How reproducible:
Always


Steps to Reproduce:
1. Setup cluster
2. start clvmd after node has joined cluster


Actual Results:
Clvmd appears to be hanging(RHEL4u6 x86_64). The lvm commands hang and
lvm commands are in 'S' state waiting on syscall connect() to finish.


Expected Results:
clvmd should start, then all the lvm commands should work correct.


Additional info:
Comment 11 Corey Marthaler 2008-02-29 17:04:42 EST
This looks like a dup of bz 217895.
Comment 49 Christine Caulfield 2008-03-18 09:29:08 EDT

*** This bug has been marked as a duplicate of 435341 ***
Comment 50 Christine Caulfield 2008-03-28 09:28:27 EDT
Corey is still seeing hangs in clvmd even with the patch for 435341.

The fix is below:

Checking in daemons/clvmd/clvmd.c;
/cvs/lvm2/LVM2/daemons/clvmd/clvmd.c,v  <--  clvmd.c
new revision: 1.45; previous revision: 1.44
done
Comment 52 Corey Marthaler 2008-04-01 16:39:30 EDT
I ran my lock stress test for 4 hours and didn't see a deadlock (I used to see
it right away), so am marking this bz verified in lvm2-cluster-2.02.27-6.el4.
Comment 54 errata-xmlrpc 2008-07-25 15:26:36 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0806.html

Note You need to log in before you can comment on or make changes to this bug.