Bug 435570 - (VIA chipset) openchrome breaks VT switching
(VIA chipset) openchrome breaks VT switching
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-openchrome (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Xavier Bachelot
Fedora Extras Quality Assurance
:
Depends On:
Blocks: LTSPHARDWARE
  Show dependency treegraph
 
Reported: 2008-03-01 17:25 EST by Warren Togami
Modified: 2009-01-09 02:41 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-09 02:41:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg.openchrome.log (29.59 KB, text/plain)
2008-03-05 15:39 EST, Warren Togami
no flags Details
lspcivvv.txt (15.99 KB, text/plain)
2008-03-05 15:39 EST, Warren Togami
no flags Details

  None (edit)
Description Warren Togami 2008-03-01 17:25:21 EST
xorg-x11-drv-openchrome-0.2.901-2.fc8
Using openchrome with full auto-configuration.  VT switching with CTRL-ALT-Fx
seems to do absolutely nothing.  I am stuck in X.
Comment 1 Matěj Cepl 2008-03-03 16:55:26 EST
Thanks for the bug report.  We have reviewed the information you have provided
above, and there is some additional information we require that will be helpful
in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf) and X server log
file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file
attachments using the bugzilla file attachment link below.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 2 Warren Togami 2008-03-03 17:04:22 EST
I currently have no way of getting the Xorg log on this machine, because I
cannot get to the VT and X is showing me a desktop on a remote machine.  I would
need to install an entire OS on a USB drive in order to get this.  It may take
some time.
Comment 3 Xavier Bachelot 2008-03-03 18:04:59 EST
Could you please at least give a bit of details on the hardware (brand and model
of motherboard/laptop, variant of the unichrome IGP, output used (VGA,laptop
panel, etc...) ?
Comment 4 Warren Togami 2008-03-05 15:38:45 EST
There is no xorg.conf, this is autoconfiguration.  Tested it on rawhide, same
problem.

xorg-x11-server-Xorg-1.4.99.900-0.28.20080304.fc9.i386
xorg-x11-drv-openchrome-0.2.901-7.fc9.i386
Comment 5 Warren Togami 2008-03-05 15:39:14 EST
Created attachment 296928 [details]
Xorg.openchrome.log

X without xorg.conf on rawhide.
Comment 6 Warren Togami 2008-03-05 15:39:39 EST
Created attachment 296929 [details]
lspcivvv.txt

lspci -vvv and lspci -vvvn
Comment 7 Xavier Bachelot 2008-03-05 18:26:59 EST
I do have a CLE266 running F8 and I don't have any problem with VT switch. As
the X server is started without a conf, could it be a problem with the keyboard
not being auto-configured properly ?
Comment 8 Warren Togami 2008-03-10 22:00:54 EDT
> could it be a problem with the keyboard not being auto-configured properly ?

The attachment of the log in Comment #5 has the autogenerated config file near
the top.  Furthermore, VT switching works fine on other chipsets booted with
exactly this same manner.

Have you tried starting X without xorg.conf yourself on your CLE266?  Might be
an interesting comparison.
Comment 9 Xavier Bachelot 2008-03-11 06:00:36 EDT
> Have you tried starting X without xorg.conf yourself on your CLE266?  Might be
> an interesting comparison.

Yes, I did and (unfortunately) it works... I did not compare the logs, but I'll
do asap. Maybe this is related to the DRI problem in RHBZ #207344.

We're currently busy putting the driver into shape for F9, it'll be nice if you
can give the F9 Beta LiveCD a try when it's out. I'll consult with upstream
about the VT/DRI problem when we have more spare cycles.
Comment 10 Bug Zapper 2008-11-26 04:59:24 EST
This message is a reminder that Fedora 8 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 8.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '8'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 8's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 8 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 11 Bug Zapper 2009-01-09 02:41:28 EST
Fedora 8 changed to end-of-life (EOL) status on 2009-01-07. Fedora 8 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.