Bug 435573 - extended repository check causes error then hard hang
extended repository check causes error then hard hang
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
All Linux
low Severity low
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2008-03-01 18:58 EST by Ray Todd Stevens
Modified: 2008-04-22 13:07 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-04-22 13:07:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Ray Todd Stevens 2008-03-01 18:58:32 EST
Description of problem:

I am getting both an error message and then a hard hang when I do something.   I
assume that they are related, but they may not be.

Version-Release number of selected component (if applicable):


How reproducible:

100% one machine.   This machine works fine with a normal install.

Steps to Reproduce:
1.start a network install (http)
2.get to the part about selecting the type of install
3.at the bottom of the screen is a check box for fedora extras, check this
4.I selected to customize now  (but you get a simlar result without this)
5.click next 

Actual results:

You will get a quick to fast to read error box with a cancel next button.  It
says something about the repository being corrupt.  But even with the next
button there it kind of "nexts" on its own.

Instead of getting the screen for detailed package selection you go right to the
"preparing to install" box.

The mouse turns to a watch and can be moved for a minute or two, then stops.  
even waiting an hour will not bring anything else up.

None of the other alt ctrl fx screens show anything, but you can go to them and
then return to the f7 and get the screen with the stuck mouse watch.

Expected results:

going on no hang

Additional info:
Comment 1 Chris Lumens 2008-03-25 14:13:21 EDT
The weirdness with buttons being clicked on their own was due to problems with
input drivers which should be fixed up now.  Are you still seeing the hang with
the input problems solved?
Comment 2 Ray Todd Stevens 2008-03-25 22:32:58 EDT
How would I try this with the new drivers.

Frankly I doubt that this will solve the problem.   But I have been wrong
before.   It looks to me that it has something to do with it failing to be able
to access "fedora extras"
Comment 3 Ray Todd Stevens 2008-04-01 10:51:05 EDT
I did just notice something.  The mirror I have been using
(chuck.ucs.indiana.edu) actually has now removed the testing repositories.   So
I had to go to a new one, and low and behold a directory which was never on
chuck exists "fedoraextras".   I wonder if the nonexistance of this directory
could be part of the problem.

On the other hand the nonexistance or failure to be accessable of a directory
would seem to be a reason for an error message not a hard hang.
Comment 4 Ray Todd Stevens 2008-04-01 11:12:53 EDT
OK this now gives a reasonable message.   Now the repository seems to be there
on the mirror i am now using, mirrors.reflected.net, but I still get a nasty
message.   But that is better than a hard hang.   A lot better.
Comment 5 Chris Lumens 2008-04-22 11:35:22 EDT
What's the status on this one?  If you enter a repo that has troubles, you get
an error message you can recover from and there's no hang?
Comment 6 Ray Todd Stevens 2008-04-22 12:21:45 EDT
Still broken on the alpha release --- who cares ;-)
Tried the beta and get a better result.

The repo definitely seems to have problems.   But now you do get an error
message, and then everything goes on hunky dorry.   So I assume someone fixed
this even if they didn't realize it.

Think we can close this one.
Comment 7 Chris Lumens 2008-04-22 13:07:33 EDT
Okay, thanks for the testing.

Note You need to log in before you can comment on or make changes to this bug.