Bug 435583 - Underquoted definition of AM_PATH_LIBDYNAMITE
Underquoted definition of AM_PATH_LIBDYNAMITE
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: dynamite (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Andreas Bierfert
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-01 22:51 EST by Jerry James
Modified: 2008-04-09 01:17 EDT (History)
0 users

See Also:
Fixed In Version: 0.1-8.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-09 01:17:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jerry James 2008-03-01 22:51:38 EST
Description of problem:
When dynamite-devel is installed, any use of the aclocal program causes this
warning message to be issued:
/usr/share/aclocal/dynamite.m4:4: warning: underquoted definition of
AM_PATH_LIBDYNAMITE
/usr/share/aclocal/dynamite.m4:4:   run info '(automake)Extending aclocal'
/usr/share/aclocal/dynamite.m4:4:   or see
http://sources.redhat.com/automake/automake.html#Extending-aclocal

This happens even when the source tree in which aclocal is invoked does not use
dynamite.

Version-Release number of selected component (if applicable):
dynamite-devel-0.1-7.fc8

How reproducible:
Always

Steps to Reproduce:
1. Install dynamite-devel
2. Run aclocal
  
Actual results:
A warning message is produced.

Expected results:
The warning message should not be produced.

Additional info:
The warning occurs because aclocal requires function names to be quoted. 
Changing line 4 of /usr/share/aclocal/dynamite.m4 to this:

AC_DEFUN([AM_PATH_LIBDYNAMITE], [

makes the warning message go away.
Comment 1 Fedora Update System 2008-03-28 19:31:19 EDT
dynamite-0.1-7.fc7 has been submitted as an update for Fedora 7
Comment 2 Fedora Update System 2008-03-28 19:33:21 EDT
dynamite-0.1-8.fc8 has been submitted as an update for Fedora 8
Comment 3 Fedora Update System 2008-04-01 17:32:09 EDT
dynamite-0.1-7.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update dynamite'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F7/FEDORA-2008-2809
Comment 4 Fedora Update System 2008-04-09 01:15:02 EDT
dynamite-0.1-7.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 5 Fedora Update System 2008-04-09 01:17:25 EDT
dynamite-0.1-8.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.