Bug 435590 - Icon theme changes not propagated to all locations
Icon theme changes not propagated to all locations
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-02 03:11 EST by Greg
Modified: 2008-07-02 03:43 EDT (History)
1 user (show)

See Also:
Fixed In Version: 2.3.0-6.14.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-22 18:41:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Example of OOo appearance issue re. high-contrast mode (39.50 KB, image/png)
2008-03-03 03:43 EST, Greg
no flags Details
"Open File" dialog with high-contrast icons (63.10 KB, image/png)
2008-03-10 16:31 EDT, Greg
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenOffice.org 60787 None None None Never
OpenOffice.org 60788 None None None Never
OpenOffice.org 60789 None None None Never
OpenOffice.org 86924 None None None Never

  None (edit)
Description Greg 2008-03-02 03:11:50 EST
Description of problem:
When using a KDE desktop theme with a dark background color ("Dark Blue" in this
case), the OpenOffice high contrast mode cannot be reliably disabled, resulting
in various appearance problems.

Version-Release number of selected component (if applicable):
2.3.0-6.11.fc8

How reproducible:
some symptoms are occasional, some occur always.

Steps to Reproduce:
1. Set KDE desktop theme to a dark-background theme like Dark Blue
2. Open openoffice
3. Create a new or open an existing presentation
4. Create a new or open an existing spreadsheet
5. Disable high contrast mode auto-detection and icons in the Options menu
6. Do #3 and #4 again
  
Actual results:
Spreadsheet cell background colors never show up.
Presentations default to black line art on the dark blue background.  Going to
the menu and setting "Color" mode to full color causes the design view slide to
show up right but preview slides on the left still do not show properly.
Occasionally, but not always, high contrast mode icons show up.  Usually the
icons are normal.  Often in the open file dialog the high contrast icons show
back up, also often in the "new document" dropdown.

Expected results:
There should be a way to reliably disable all high contrast mode forms of
operation and have OpenOffice function normally regardless of desktop color
scheme.  Maybe I am missing some configuration setting or whatnot, but the
behavior is indicating to me a programming oversight in OOo.

Additional info:
Comment 1 Caolan McNamara 2008-03-03 03:23:37 EST
a) What does tools->options->openoffice.org->view->icon size and style say ?
b) Do you have accessibility feature enabled in your desktop ?, e.g. 
what's the output of gconftool-2 -g "/desktop/gnome/interface/accessibility" to
see the setting from GNOME/OOo's perspective.
Comment 2 Greg 2008-03-03 03:32:22 EST
a) Size "Small", Style "Crystal".  Originally, the high-contrast mode kicked in
and all of the icons were the "high contrast" ones.  After changing the
aforementioned setting is when *most* icons were normal, and occasionally icons
were high-contrast.

b) "false"
Comment 3 Caolan McNamara 2008-03-03 03:41:55 EST
"Originally...." "After changing"... what was the setting changed from,
"automatic" ?
Comment 4 Greg 2008-03-03 03:43:36 EST
Created attachment 296563 [details]
Example of OOo appearance issue re. high-contrast mode

Notes:
- some icons are normal, some high-contrast.
- righthand side design view pane views the document normally (once View ->
Color -> Color is selected)
- lefthand side preview/list pane shows all pages in lineart only (doing View
-> Color -> Color with that pane selected causes the list background to turn
white but the slides are still in lineart only)
Comment 5 Greg 2008-03-03 03:45:26 EST
(In reply to comment #3)
> "Originally...." "After changing"... what was the setting changed from,
> "automatic" ?

I am actually unsure.  I had not changed that setting previously though.  It was
either "Automatic" or "HiContrast".
Comment 6 Caolan McNamara 2008-03-10 15:58:44 EDT
I can reproduce something *similar* to this, but not exactly the same. 

With that "Dark Blue" background under KDE on F-8 and automatic icons, and then
display the menu on your screenshot it is in hicontrast mode. If I then change
the OOo icon set to crystal that menu remains in hicontrast, like there's a
cached set of icons that aren't flushed by the change, but on stop and restart
of OOo the crystal icons are used.

That's not your experience though is it, you have a mix of icons always, right ?
Comment 7 Caolan McNamara 2008-03-10 16:11:46 EDT
Testing with to-be F9 seems to show that what I can reproduce in F-8 doesn't
happen in F-9 which is good on that front at least.
Comment 8 Greg 2008-03-10 16:30:20 EDT
I had restarted before and it didn't fix the icons (not sure, but the restart
may have been due to an OOo crash), but this time I restarted and the New
Document dropdown menu icons are correct.  However the Open File dialog icons
are still high-contrast -- see attachment.
Comment 9 Greg 2008-03-10 16:31:07 EDT
Created attachment 297509 [details]
"Open File" dialog with high-contrast icons
Comment 10 Caolan McNamara 2008-03-11 09:24:05 EDT
found two places where the icon change wasn't getting propagated, fix checked in
and upstreamed. Will be in >= 2.4.0-10.2 for F9 and 2.3.0-6.12 for F8
Comment 11 Greg 2008-03-11 13:49:32 EDT
Due to the change in the bug summary, should I resubmit a new bug for the other
high-contrast mode problems I've described here?
Comment 12 Caolan McNamara 2008-03-13 07:13:31 EDT
No, I think upstream is actually aware of the other ones, we just need to get
them to check what's fixed and what might not be with this patch, so in theory
we're on top of this now
Comment 13 Fedora Update System 2008-03-20 04:07:39 EDT
openoffice.org-2.3.0-6.12.fc8 has been submitted as an update for Fedora 8
Comment 14 Fedora Update System 2008-03-21 18:02:09 EDT
openoffice.org-2.3.0-6.12.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update openoffice.org'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F8/FEDORA-2008-2552
Comment 15 Fedora Update System 2008-04-08 14:40:48 EDT
openoffice.org-2.3.0-6.13.fc8 has been submitted as an update for Fedora 8
Comment 16 Fedora Update System 2008-04-17 14:38:36 EDT
openoffice.org-2.3.0-6.14.fc8 has been submitted as an update for Fedora 8
Comment 17 Fedora Update System 2008-04-22 18:40:51 EDT
openoffice.org-2.3.0-6.14.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 18 Yolkfull Chow 2008-07-02 03:43:21 EDT
This problem cannot be reproduced on F9.

Note You need to log in before you can comment on or make changes to this bug.