Bug 435594 - mpd backend doesn't work
mpd backend doesn't work
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: gnome-applet-music (Show other bugs)
8
All Linux
low Severity medium
: ---
: ---
Assigned To: Peter Gordon
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-02 04:19 EST by Jakub 'Livio' Rusinek
Modified: 2008-03-03 00:29 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-03 00:29:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jakub 'Livio' Rusinek 2008-03-02 04:19:20 EST
Description of problem:
gnome-applet-music requires mpdclient for mpd support, while libmpd is provided
in repos instead. this doesn't work.
Comment 1 Peter Gordon 2008-03-03 00:29:44 EST
The package includes the mpdclient2 support as a courtesy to users, since it is
provided by upstream. However, this is on the assumption that the user has
appropriately installed the python mpdclient2 module in a manual fashion.

As it stands, the only "upstream" that I am aware of for this module is the
tarball itself (from http://pygmy.berlios.de/files/ according to the Debian
package for it). However, that is more than 2 years old and has no formal
packaging (as the README in the tarball states). 

Alas, I have no interest in supporting MPD more than simply including what
upstream has created. I especially do not care to do so with such an outdated
and completely unofficial tarball. That said, if you would like to submit and
maintain such a package for Fedora (knowing full well that its upstream is
essentially dead), please feel free to do so. 

Otherwise, you need to install the mpdclient2 module manually, which Music
Applet will then find and be able to use.

Closing as WONTFIX.

Note You need to log in before you can comment on or make changes to this bug.