Bug 4356 - ld dies with signal 11 when linking very big programs
ld dies with signal 11 when linking very big programs
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: binutils (Show other bugs)
6.0
sparc Linux
medium Severity high
: ---
: ---
Assigned To: David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-08-04 15:56 EDT by megastep
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-08-08 09:22:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description megastep 1999-08-04 15:56:58 EDT
When trying to compile Civ: CTP for Sparc/Linux, ld died
with a 200MB core file. There is a lot of big object files
in this project, so maybe ld can't handle that much on
Sparc.
Comment 1 Jeff Johnson 1999-08-06 13:36:59 EDT
Make sure that everything that you are linking with was compiled
with -fPIC. On sparc there is also a -fpic, but that will fail
when your link is too large ...
Comment 2 Jim Kingdon 1999-08-08 09:22:59 EDT
I'm not sure -fpic rather than -fPIC
would explain this (if that is the problem,
ld is supposed to give an error that the global offset table filled
up, at least according to the GCC manual).

Make sure you have lots of virtual memory (while running out of data
space should produce something more like "out of memory", running
out of stack space will produce a sig11).  Make sure that ulimit
is set to allow enough stack space (see "man bash" re ulimit).

If those don't help, I'm not sure we can do much more to help.
Comment 3 Jim Kingdon 1999-08-23 13:56:59 EDT
I talked with a few of the Loki guys at LinuxWorld and they say
that the problem was indeed that they didn't have enough swap
space.

Note You need to log in before you can comment on or make changes to this bug.