Bug 435607 - rpc.rquotad opens pop3s listen port, prevents dovecot from starting
rpc.rquotad opens pop3s listen port, prevents dovecot from starting
Status: CLOSED DUPLICATE of bug 223937
Product: Fedora
Classification: Fedora
Component: quota (Show other bugs)
8
i686 Linux
low Severity low
: ---
: ---
Assigned To: Ondrej Vasik
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-02 09:37 EST by josip
Modified: 2008-03-02 12:06 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-02 12:06:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description josip 2008-03-02 09:37:16 EST
Description of problem:

/usr/sbin/rpc.rquotad sometimes opens pop3s listen port and prevents dovecot
from starting (dovecot needs that standard port).

Version-Release number of selected component (if applicable):

quota-3.14-1.fc7

How reproducible:

Restart system.  The problem is apparently intermittent.

Steps to Reproduce:
1.Reboot
2.Intermittent problems
3.
  
Actual results:

/usr/sbin/rpc.rquotad process interferes with dovecot start due to listen port
995 (pop3s):

# lsof -p 2087
COMMAND    PID USER   FD   TYPE DEVICE     SIZE    NODE NAME
rpc.rquot 2087 root  cwd    DIR    8,2     4096       2 /
rpc.rquot 2087 root  rtd    DIR    8,2     4096       2 /
rpc.rquot 2087 root  txt    REG    8,2    72296 1949872 /usr/sbin/rpc.rquotad
rpc.rquot 2087 root  mem    REG    8,2   128952   32778 /lib/ld-2.7.so
rpc.rquot 2087 root  mem    REG    8,2    32952   33195 /lib/libwrap.so.0.7.6
rpc.rquot 2087 root  mem    REG    8,2  1692524   32874 /lib/libc-2.7.so
rpc.rquot 2087 root  mem    REG    8,2   109580   33224 /lib/libnsl-2.7.so
rpc.rquot 2087 root  mem    REG    8,2    52620   33196 /lib/libnss_files-2.7.so
rpc.rquot 2087 root  mem    REG    8,2 79319968 1934239
/usr/lib/locale/locale-archive
rpc.rquot 2087 root    0u   CHR    1,3              198 /dev/null
rpc.rquot 2087 root    1u   CHR    1,3              198 /dev/null
rpc.rquot 2087 root    2u   CHR    1,3              198 /dev/null
rpc.rquot 2087 root    3u  IPv4   5127              UDP *:telnets 
rpc.rquot 2087 root    4u  IPv4   5133              TCP *:pop3s (LISTEN)

# service dovecot start
Starting Dovecot Imap: Fatal: listen(995) failed: Address already in use
                                                           [FAILED]

Expected results:

rpc.rquotad should be using its own default port RQUOTAD_PORT=875, not
995(pop3s) port

Additional info:

This behavior was seen with unmodified /etc/sysconfig/nfs file.  The system is
running fully updated Fedora 8 i686, but interestingly enough the quota package
release is "1.fc7" even though it comes from Fedora 8 depository.
Comment 1 Ondrej Vasik 2008-03-02 12:06:51 EST
Thanks for report and suggestion, but it is duplicate of #223937 . I'm quota
maintainer for about 1 month, so I'm trying to get it into shape, but it will
take some time. Closing that one as DUPLICATE.
About 1.fc7 - that was because quota package was not rebuilt between F7 and F8
release. 

*** This bug has been marked as a duplicate of 223937 ***

Note You need to log in before you can comment on or make changes to this bug.