This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 435609 - kernel-2.6.24.3-12.fc8 from updates-testing won't boot on VIA C3 / C7 boards
kernel-2.6.24.3-12.fc8 from updates-testing won't boot on VIA C3 / C7 boards
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
8
i686 Linux
low Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-02 09:54 EST by Peter Bieringer
Modified: 2008-03-26 13:15 EDT (History)
4 users (show)

See Also:
Fixed In Version: 2.6.24.3-50.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-26 13:15:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Screenshot of kernel bug (324.54 KB, image/png)
2008-03-02 09:54 EST, Peter Bieringer
no flags Details

  None (edit)
Description Peter Bieringer 2008-03-02 09:54:45 EST
Description of problem:
Kernel from updates-testing won't boot at all.

Version-Release number of selected component (if applicable):
kernel-2.6.24.3-12.fc8

How reproducible:
Every boot try

Steps to Reproduce:
1. Install kernel
2. Check grub config
3. Select this kernel and try to boot
  
Actual results:
Won't work, reports
Bug INT6 CR2...

Expected results:
Proper booting

I couldn't catch this error via serial console, so I took a real screen shot and
attached it.
Comment 1 Peter Bieringer 2008-03-02 09:54:45 EST
Created attachment 296512 [details]
Screenshot of kernel bug
Comment 2 Chuck Ebbert 2008-03-03 16:17:35 EST
Caould this be caused by trying to boot an i686 kernel on i586-class hardware?
Comment 3 Chuck Ebbert 2008-03-03 16:44:05 EST
Should be fixed by this:

Commit:     959b3be64cab9160cd74532a49b89cdd918d38e9
    x86: don't use P6_NOPs if compiling with CONFIG_X86_GENERIC
Comment 4 Peter Bieringer 2008-03-03 16:48:07 EST
Regarding https://bugzilla.redhat.com/show_bug.cgi?id=435609#c2, not really,
kernels up to 2.6.23 i686 are booting well:

$ rpm -q kernel --queryformat "%{name}-%{version}-%{release} %{arch}\n"
kernel-2.6.23.15-137.fc8 i686
kernel-2.6.24.3-12.fc8 i686
Comment 5 Peter Bieringer 2008-03-03 16:51:33 EST
BTW: does https://bugzilla.redhat.com/process_bug.cgi#c3 result in that 2.6.24
i686 kernel do no longer boot on VIA C3 / C7 CPUs? Then one have to adjust the
arch detection, because currently:

# cat /proc/cpuinfo 
processor       : 0
vendor_id       : CentaurHauls
cpu family      : 6
model           : 9
model name      : VIA Nehemiah
stepping        : 10
cpu MHz         : 800.055
cache size      : 64 KB
fdiv_bug        : no
hlt_bug         : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 1
wp              : yes
flags           : fpu vme de pse tsc msr cx8 apic mtrr pge cmov pat mmx fxsr sse
up rng rng_en ace ace_en
bogomips        : 1601.77
clflush size    : 32

Should I switch to i586 kernel?
Comment 6 Chuck Ebbert 2008-03-03 17:07:58 EST
Should be fixed in 2.6.24.3-14.
Comment 7 Fedora Update System 2008-03-07 14:24:18 EST
kernel-2.6.24.3-22.fc8 has been submitted as an update for Fedora 8
Comment 8 Giandomenico De Tullio 2008-03-08 07:00:19 EST
(In reply to comment #7)
> kernel-2.6.24.3-22.fc8 has been submitted as an update for Fedora 8

don't boot (see #1) on my headless "firewall"

# cat /proc/cpuinfo 
processor       : 0
vendor_id       : CentaurHauls
cpu family      : 6
model           : 9
model name      : VIA Nehemiah
stepping        : 8
cpu MHz         : 1002.293

flags           : fpu vme de pse tsc msr cx8 mtrr pge cmov pat mmx fxsr sse up
rng rng_en ace ace_en
bogomips        : 2006.15
clflush size    : 32

Comment 9 Fedora Update System 2008-03-13 17:58:19 EDT
kernel-2.6.24.3-34.fc8 has been submitted as an update for Fedora 8
Comment 10 Warren Togami 2008-03-14 00:14:08 EDT
Earlier i686 kernels have worked on this VIA box?  Specifically what versions?
 
Comment 11 Peter Bieringer 2008-03-14 02:47:36 EDT
Yes, kernel-2.6.23.15-137.fc8 i686 (see
https://bugzilla.redhat.com/show_bug.cgi?id=435609#c4) works.
Comment 12 Fedora Update System 2008-03-16 15:27:45 EDT
kernel-2.6.24.3-34.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 13 Peter Onion 2008-03-17 15:35:13 EDT
I just tried 2.6.24.3-34-fc8 in a VIA C3 based system.  The bug is still present :(
processor       : 0
vendor_id       : CentaurHauls
cpu family      : 6
model           : 9
model name      : VIA Nehemiah
stepping        : 5
cpu MHz         : 999.832
cache size      : 64 KB
fdiv_bug        : no
hlt_bug         : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 1
wp              : yes
flags           : fpu de pse tsc msr cx8 mtrr pge cmov mmx fxsr sse up rng rng_en
bogomips        : 2000.97
clflush size    : 32
Comment 14 Chuck Ebbert 2008-03-18 11:21:28 EDT
Revised fix is in 2.6.23.3-41
Comment 15 M C 2008-03-19 23:48:51 EDT
Hello,

I'm brand new to Linux and I installed Fedora 8 two days ago.  Everything worked
great.  I guess some form of auto-update ran (yum?) on my first boot and I let
that run overnight.  In the morning when I had it reboot, I received the same
crash error (BUG: Int 6: CR2 ...).  I downloaded my copy of Fedora from the
BitTorrent link on the main website.

From the startup menu (grub?), I'm able to get into the version of the kernel
that I downloaded (2.6.23.1-42.fc8), but if I let the default top choice be
selected(2.6.24.3-34.fc8), the crash repeats every time.

I've seen people posting this information above, so if it's helpful I've
provided it here.

[x@localhost ~]$ rpm -q kernel --queryformat "%{name}-%{version}-%{release}
%{arch}\n"
kernel-2.6.23.1-42.fc8 i686
kernel-2.6.24.3-34.fc8 i686
[x@localhost ~]$ cat /proc/cpuinfo
processor       : 0
vendor_id       : CentaurHauls
cpu family      : 6
model           : 9
model name      : VIA Nehemiah
stepping        : 1
cpu MHz         : 999.572
cache size      : 64 KB
fdiv_bug        : no
hlt_bug         : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 1
wp              : yes
flags           : fpu de tsc msr cx8 mtrr pge cmov mmx fxsr sse fxsr_opt up
bogomips        : 2000.33
clflush size    : 32

If there is a way for me to test 2.6.23.3-41 as posted in
https://bugzilla.redhat.com/show_bug.cgi?id=435609#c14, I would be more than
happy to help, but I need to know what commands to run to do so.

Comment 16 Simon Farnsworth 2008-03-20 06:20:45 EDT
I've just tested 2.6.24.3-48, from
http://koji.fedoraproject.org/packages/kernel/2.6.24.3/48.fc8/i686/kernel-2.6.24.3-48.fc8.i686.rpm;
this works for me.

Cpuinfo from the working 2.6.24.3-48 kernel:
 # cat /proc/cpuinfo 
processor       : 0
vendor_id       : CentaurHauls
cpu family      : 6
model           : 9
model name      : VIA Nehemiah
stepping        : 8
cpu MHz         : 999.874
cache size      : 64 KB
fdiv_bug        : no
hlt_bug         : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 1
wp              : yes
flags           : fpu vme de pse tsc msr cx8 mtrr pge cmov pat mmx fxsr sse up
rng rng_en ace ace_en
bogomips        : 2001.00
clflush size    : 32

Can someone please push this kernel into F8 updates?
Comment 17 Peter Bieringer 2008-03-20 15:23:10 EDT
2.6.24.3-48 works for me, too now. Thank you!
Comment 18 Fedora Update System 2008-03-20 23:15:24 EDT
kernel-2.6.24.3-50.fc8 has been submitted as an update for Fedora 8
Comment 19 Fedora Update System 2008-03-21 18:16:43 EDT
kernel-2.6.24.3-50.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update kernel'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F8/FEDORA-2008-2630
Comment 20 Fedora Update System 2008-03-26 13:14:53 EDT
kernel-2.6.24.3-50.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.