Bug 435633 - no xv using vn800 on laptop
no xv using vn800 on laptop
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-openchrome (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Xavier Bachelot
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-02 14:14 EST by Martin Jürgens
Modified: 2008-03-07 03:55 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-07 03:55:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xorg.conf (1.60 KB, text/plain)
2008-03-05 11:56 EST, Martin Jürgens
no flags Details
Xorg.0.log (54.49 KB, text/plain)
2008-03-05 11:57 EST, Martin Jürgens
no flags Details
Xorg.0.log with working Xv (54.52 KB, text/plain)
2008-03-06 04:09 EST, Martin Jürgens
no flags Details

  None (edit)
Description Martin Jürgens 2008-03-02 14:14:48 EST
Description of problem:


Version-Release number of selected component (if applicable):
xorg-x11-drv-openchrome-0.2.901-2.fc8

How reproducible:
Every time

Steps to Reproduce:
1. Play video on laptop
2.
3.
  
Actual results:
No video / black screen

Expected results:
Video

Additional info:
When using an external display, it works. Maybe we can find out how to fix the
issue here? I tried it some times using IRC, but that is not a good way to do
complex QA. Thanks.
Comment 1 Xavier Bachelot 2008-03-03 18:01:26 EST
Yup, upstream knows about this one, but nobody fixed it yet. I'll ask again,
though. Meanwhile, please attach your xorg conf and xorg log.

Regards,
Xavier
Comment 2 Martin Jürgens 2008-03-05 11:56:52 EST
Created attachment 296896 [details]
xorg.conf
Comment 3 Martin Jürgens 2008-03-05 11:57:18 EST
Created attachment 296897 [details]
Xorg.0.log
Comment 4 Martin Jürgens 2008-03-05 11:58:35 EST
I saw some mailing about a new laptop panel code on the mailinglist. Do you
think that this could solve the issue?
Comment 5 Xavier Bachelot 2008-03-05 12:06:27 EST
(In reply to comment #4)
> I saw some mailing about a new laptop panel code on the mailinglist. Do you
> think that this could solve the issue?

No, this new code is unrelated. It allows to do the modesetting without the help
of VBE. I'd really appreciate if you can give a try to the randr branch, but
unfortunately, this code will not run on Rawhide (it lacks the libpciaccess
code), so unless you still have a Fedora 7 or 8 to test, it's useless.
Comment 6 Xavier Bachelot 2008-03-05 18:58:06 EST
Martin, here are 2 koji scratch builds with a possible fix for this pb : 
rawhide : http://koji.fedoraproject.org/koji/taskinfo?taskID=495634
F8: http://koji.fedoraproject.org/koji/taskinfo?taskID=495668

Lemme know if it helps.

btw, I'm confused are you running F8 or Rawhide ?
Comment 7 Martin Jürgens 2008-03-06 01:31:40 EST
rawhide. The time I reported that bug I was running F8, but I upgraded to
rawhide soon after ;) I will let you know about the results when I am back home.
Comment 8 Martin Jürgens 2008-03-06 04:08:47 EST
With the packes from Koji, it works fine (which is good as it did not work for
nearly 2 years :)). Xorg.0.log attached.
Comment 9 Martin Jürgens 2008-03-06 04:09:37 EST
Created attachment 297013 [details]
Xorg.0.log with working Xv

Thanks. I love you!!
Comment 10 Xavier Bachelot 2008-03-07 03:55:14 EST
Fixed in Rawhide :
xorg-x11-drv-openchrome-0.2.901-9.fc9

I'll push a F8 package asap.

Note You need to log in before you can comment on or make changes to this bug.