This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 435640 - hal doesn't see virtio devices
hal doesn't see virtio devices
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: hal (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: David Zeuthen
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F9Blocker
  Show dependency treegraph
 
Reported: 2008-03-02 15:46 EST by Jeremy Katz
Modified: 2013-03-05 22:55 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-03 17:00:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Support for virtio devices (3.86 KB, patch)
2008-03-02 16:44 EST, Jeremy Katz
no flags Details | Diff

  None (edit)
Description Jeremy Katz 2008-03-02 15:46:08 EST
The new virtio (http://kvm.qumranet.com/kvmwiki/Virtio) virtual devices which
are available to provide PV drivers to KVM and other virt technologies don't
seem to be showing up in hal.  It looks like we just need to add support for the
"virtio" bus
Comment 1 Jeremy Katz 2008-03-02 16:44:01 EST
Created attachment 296524 [details]
Support for virtio devices

This seems to do the trick to add support for finding the devices.   The disk
still isn't found, but that looks like it's because we're missing the block
symlink in the device directory ==> kernel problem.
Comment 2 Jeremy Katz 2008-03-02 17:04:58 EST
And kernel patch for virtio disks to show up properly sent upstream.

Note You need to log in before you can comment on or make changes to this bug.