Bug 435646 - Cannot create a userdefined schema object
Cannot create a userdefined schema object
Status: CLOSED DUPLICATE of bug 234948
Product: 389
Classification: Community
Component: Directory Console (Show other bugs)
1.1.0
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Rich Megginson
Chandrasekar Kannan
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-02 20:23 EST by Frank Delahoyde
Modified: 2015-01-04 18:31 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-03 11:44:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
stack trace from fedora-idm-console and 63sudo.ldif (3.53 KB, text/plain)
2008-03-02 20:23 EST, Frank Delahoyde
no flags Details

  None (edit)
Description Frank Delahoyde 2008-03-02 20:23:27 EST
Description of problem:

I have a userdefined schema for sudoers
(/etc/dirsrv/slapd*/schema/63sudoers.ldif). This schema works fine with
command line utilities, but when I try to create a new sudoRole object
from the console (New->Other->sudorole) I get a java exception. Both
my directory and admin servers use tls, if it matters. And I have
2-way multimaster replicated servers, running on CentOS-5,1 x86_64.

Version-Release number of selected component (if applicable):

fedora-ds-console-1.1.0-5.fc6
fedora-ds-base-1.1.0-3.fc6
fedora-admin-console-1.1.0-4.fc6
fedora-idm-console-1.1.0-5.fc6
fedora-ds-1.1.0-3.fc6
fedora-ds-admin-1.1.1-1.fc6

How reproducible:

every time. I have removed the schema and reinstalled it numerous times,
and even reinstalled my servers.

Steps to Reproduce:
1. Add the schema 63sudoers.ldif to a server instance. Restart the server.
2. Open the directory console and attempt to add a sudorole object
3.
  
Actual results:

Exception in thread "AWT-EventQueue-0" java.lang.NullPointerException

Expected results:

A property editor window for the new object.

Additional info:
Comment 1 Frank Delahoyde 2008-03-02 20:23:27 EST
Created attachment 296531 [details]
stack trace from fedora-idm-console and 63sudo.ldif
Comment 2 Frank Delahoyde 2008-03-02 20:30:21 EST
I should add that I have several other userdefined schemas that work
fine with the console, and that I am able to open the property editor
on an existing sudorole object.
Comment 3 Rich Megginson 2008-03-03 11:44:24 EST

*** This bug has been marked as a duplicate of 234948 ***
Comment 4 Chandrasekar Kannan 2008-08-11 19:55:33 EDT
Bug already CLOSED. setting screened+ flag

Note You need to log in before you can comment on or make changes to this bug.