Bug 435653 - ACPI Exception (processor_core-0819): AE_NOT_FOUND, Processor Device is not present [20070126]
ACPI Exception (processor_core-0819): AE_NOT_FOUND, Processor Device is not p...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
low Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-02 21:05 EST by Joshua Covington
Modified: 2008-11-07 05:16 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-07 05:15:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
the bios change log file (12.66 KB, text/plain)
2008-03-02 21:05 EST, Joshua Covington
no flags Details
bios version 3315 (binary file from the acer server) (1.00 MB, application/octet-stream)
2008-03-02 21:07 EST, Joshua Covington
no flags Details
my log after flashing back to 3303. see line 204 (44.77 KB, text/plain)
2008-03-02 21:07 EST, Joshua Covington
no flags Details
dmesg with noapic option (28.47 KB, application/octet-stream)
2008-03-10 20:34 EDT, Joshua Covington
no flags Details
cpuinfo (1.25 KB, application/octet-stream)
2008-03-10 20:43 EDT, Joshua Covington
no flags Details
/proc/iomem (1.55 KB, application/octet-stream)
2008-03-10 20:44 EDT, Joshua Covington
no flags Details
/proc/ioports (1.34 KB, application/octet-stream)
2008-03-10 20:44 EDT, Joshua Covington
no flags Details
lspci -vvv (22.72 KB, application/octet-stream)
2008-03-10 20:44 EDT, Joshua Covington
no flags Details
/proc/modules (3.22 KB, application/octet-stream)
2008-03-10 20:45 EDT, Joshua Covington
no flags Details
/proc/scsi/scsi (336 bytes, application/octet-stream)
2008-03-10 20:45 EDT, Joshua Covington
no flags Details
photo (1.54 MB, image/jpeg)
2008-03-15 13:13 EDT, Joshua Covington
no flags Details
kernel panic photo (1.47 MB, image/jpeg)
2008-03-16 02:34 EDT, Joshua Covington
no flags Details
mk36 error 1 (1.41 MB, image/jpeg)
2008-03-16 12:33 EDT, Joshua Covington
no flags Details
mk36 error 2 (1.34 MB, image/jpeg)
2008-03-16 12:34 EDT, Joshua Covington
no flags Details
my custom DSDT table (229.07 KB, patch)
2008-05-19 20:38 EDT, Joshua Covington
no flags Details | Diff
Propoced patch from ykzhao (2.10 KB, patch)
2008-08-04 11:22 EDT, Joshua Covington
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Linux Kernel 10237 None None None Never
Linux Kernel 8953 None None None Never

  None (edit)
Description Joshua Covington 2008-03-02 21:05:50 EST
Description of problem:

After bios update the kernel cannot find my processor. windows xp has no
problems with the bios update.
I have acer aspire 5051 and it came with bios 3103. later i updated it to 3109
and 3303. After this 3309 and 3315 were releases. (see the attached file with
the bios specifications. it is downloaded from the official acer site).
Some months ago i tried with 3309 and i saw a kernel panic. the message was
something with the thermal table, as far as i can now remember. yesterday i
flashed 3315 and when booting the kernel it stops after the following line:

ACPI Exception (processor_core-0819): AE_NOT_FOUND, Processor Device is not
present [20070126]
Switched to high resolution mode on CPU 0

The difference is that with 3309 (the kernel version at that time was 2.6.19 or
20) i saw "kernel panic". now it tries to load the kernel and stops without the
kernel panic message. 

the bios file says, that after 3303 the cpu code has been updated. maybe this is
the problem. anyway my fedora boots only with bios 3303.

Version-Release number of selected component (if applicable):
kernel-2.6.23.15-137.fc8


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:

the kernel team can repair this.


Additional info:
Attached files:

ZR3_NOTE.txt -> the bios chage log file
messages.log -> my log after flashing back to 3303. see line 204. it has exactly
the same messages as i saw with bios 3315. but with 3303 i have no problems
ZR3_3315.wph -> the actual bios version 3315 (binary file from the acer server)
Comment 1 Joshua Covington 2008-03-02 21:05:50 EST
Created attachment 296536 [details]
the bios change log file
Comment 2 Joshua Covington 2008-03-02 21:07:11 EST
Created attachment 296537 [details]
bios version 3315 (binary file from the acer server)
Comment 3 Joshua Covington 2008-03-02 21:07:56 EST
Created attachment 296538 [details]
my log after flashing back to 3303. see line 204
Comment 4 Chuck Ebbert 2008-03-03 17:18:00 EST
Can you try kernel 2.6.24.3-12 from the updates-testing repository?
This looks like a thermal zone problem, since that's the next line that prints
when it works...
Comment 5 Joshua Covington 2008-03-03 19:02:02 EST
what is your idea about this? in the next version of the bios they've added some
new thermal info about another amd processor. but as far as the processor
identifies itself correctly this shouldn't be a problem. maybe the bios expects
another info or function arguments when asked about the cpu and therefore it
cannot send the info to the kernel, which results in the "no processor found"
message.

about testing - i have to reflash the newest bios first and then do the testing.
and i don't see any new updates to the acpi code in the kernel.should it work
with the 2.6.24.3-12.fc8? maybe it is a faulty bios but windows works with it.
Comment 6 Chuck Ebbert 2008-03-05 18:45:23 EST
There were lots of ACPI updates in 2.6.24.
Comment 7 Joshua Covington 2008-03-10 19:46:55 EDT
After the error occurs it flashes some info on the display (stack data and so
on). how can i report this here? I cannot extract the info because it is flashed
too quickly on the display and i cannot even start the kernel.
Comment 8 Joshua Covington 2008-03-10 20:32:09 EDT
ok, i managed to start the kernel. tried the nolapic and got stacked. so i tried
the noapic and it started(delete quiet and rhgb and add noapic). now i have no
wireless (madwifi) but atleast the fedora is back. here is the dmesg with the
noapic argument.
Comment 9 Joshua Covington 2008-03-10 20:34:33 EDT
Created attachment 297540 [details]
dmesg with noapic option
Comment 10 Joshua Covington 2008-03-10 20:43:44 EDT
Created attachment 297541 [details]
cpuinfo
Comment 11 Joshua Covington 2008-03-10 20:44:10 EDT
Created attachment 297542 [details]
/proc/iomem
Comment 12 Joshua Covington 2008-03-10 20:44:31 EDT
Created attachment 297543 [details]
/proc/ioports
Comment 13 Joshua Covington 2008-03-10 20:44:55 EDT
Created attachment 297544 [details]
lspci -vvv
Comment 14 Joshua Covington 2008-03-10 20:45:15 EDT
Created attachment 297545 [details]
/proc/modules
Comment 15 Joshua Covington 2008-03-10 20:45:35 EDT
Created attachment 297546 [details]
/proc/scsi/scsi
Comment 16 Joshua Covington 2008-03-10 20:49:48 EDT
all atachments are made after flashing back bios 3315. according to the change
log the cpu microcode has been updated since bios 3303. and now I'm with turion
tl-60. with this processor there is no more ACPI exception error but a kernel
panic. but i don't know how to attach the info because without the noapic option
the kernel won't boot.
Comment 17 Chuck Ebbert 2008-03-13 16:23:03 EDT
Can you take a picture of the screen or does it scroll off?
Comment 18 Joshua Covington 2008-03-15 13:13:04 EDT
Created attachment 298152 [details]
photo

actually i didn't get kernel panic this time (for a first time and i don't kow
why).the kernel was started with no arguments.
Comment 19 Joshua Covington 2008-03-16 02:34:19 EDT
Created attachment 298179 [details]
kernel panic photo

ok, now i have a photo of the kernel panic error. it occurrs when the coomputer

is cold (started after cooled off)
Comment 20 Joshua Covington 2008-03-16 12:33:12 EDT
Created attachment 298195 [details]
mk36 error 1

this is a photo of the error that i got with turion mk36 processor. it is the
same mashine as before but i've changed the cpus.
Comment 21 Joshua Covington 2008-03-16 12:34:57 EDT
Created attachment 298196 [details]
mk36 error 2

another photo of the bug with mk36 processor. i have no kernel panic here. the
panic occurrs only with the tl-60 processor.
Comment 22 Joshua Covington 2008-05-19 20:38:37 EDT
Created attachment 306038 [details]
my custom DSDT table

This is the custom DSDT table that fixes the problem. it is an error in the
Bios that should be fixed by acer. until then i have to recompile every kernel
and insert the table manually.
Comment 23 Joshua Covington 2008-08-04 11:19:35 EDT
Yakui Zhao made a patch about this but there is a discussion on kernel-acpi if this should go mainstream. here it is: http://marc.info/?t=121746991200002&r=1&w=2
. I don't know if this is going to end in the mainstream soon, but can we have this in the fedora kernel as a platform-resolution (hopefully).

Can this patch be considered?
--joshua
Comment 24 Joshua Covington 2008-08-04 11:22:08 EDT
Created attachment 313366 [details]
Propoced patch from ykzhao

I tested this with 2.6.25.11-60.fc8, 2.6.25.14-67.fc8 and 2.6.27.rc1.git3.fc8. Works fine.
Comment 25 Joshua Covington 2008-11-05 14:32:06 EST
A Patch for this was included in 2.6.28.rc1

commit 20edd74fcf9ad02c19efba0c13670a7b6b045099
Author: Zhao Yakui <yakui.zhao@intel.com>
Date:   Fri Oct 17 02:02:44 2008 -0400

    ACPI: Ignore AE_NOT_FOUND error of EC _REG method and continue to
initialize EC

Can this be included in the release kernel for cambridge so that we can have it in the public release of fedora 10? Please.
Comment 26 Dave Jones 2008-11-05 16:17:05 EST
added for 2.6.27.4-81
Comment 27 Joshua Covington 2008-11-07 05:16:20 EST
Thank you.

Note You need to log in before you can comment on or make changes to this bug.