Bug 435697 - No swap in diskless environment
No swap in diskless environment
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: system-config-netboot (Show other bugs)
4.6
All Linux
low Severity low
: rc
: ---
Assigned To: Jaroslav Reznik
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-03 08:21 EST by Ondrej Valousek
Modified: 2010-04-06 07:21 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-04-06 07:21:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ondrej Valousek 2008-03-03 08:21:06 EST
Description of problem:
I am trying to configure swap for diskless workstations using the local HDD by
modifying /etc/fstab to contain something like:
/dev/sda        swap            swap    defaults        0 0
but it does not work - the swap is not activated during the boot procedure.
Later manual activation by swapon -a command works fine.

Further investigation shows that the problem cause is the fact, that the block
device /dev/sda is not known to the system at the time /etc/rc.d/rc.sysinit
script is being executed.

Version-Release number of selected component (if applicable):


How reproducible:
always

Steps to Reproduce:
1. install a HDD into the machine booting via network
2. modify /etc/fstab to contain local swap partition on that hdd.
3. boot
  
Actual results:
no swap is activated

Expected results:
swap is activated as per configuration in /etc/fstab

Additional info:
Comment 1 Ondrej Valousek 2008-05-06 08:16:51 EDT
It turned out, that the hardware initialization is too early followed by the
attempt to active the swap so that the necessary block device in /dev is not yet
created.
The simple workaround to this problem is adding some small delay (sleep 5 in my
case seems to be sufficient) to the /etc/rc.d/rc.sysinit startup script before
activating the swap.
Ondrej
Comment 3 Jaroslav Reznik 2010-04-06 07:21:25 EDT
System-config-netboot is now in maintenance mode only, no further development
is planned for RHEL 4.x. Closing as WONTFIX. I'm not sure about exact sleep time before swap activation.

Note You need to log in before you can comment on or make changes to this bug.