Bug 435730 - Allow fractional replication between masters
Allow fractional replication between masters
Status: CLOSED ERRATA
Product: 389
Classification: Community
Component: Replication - Fractional (Show other bugs)
1.1.0
All Linux
low Severity low
: ---
: ---
Assigned To: Nathan Kinder
Chandrasekar Kannan
:
Depends On:
Blocks: 249650
  Show dependency treegraph
 
Reported: 2008-03-03 11:15 EST by Nathan Kinder
Modified: 2015-01-04 18:31 EST (History)
2 users (show)

See Also:
Fixed In Version: RHBA-2008-0203
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-01 12:06:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Proposed Fix (3.51 KB, patch)
2008-03-03 11:31 EST, Nathan Kinder
no flags Details | Diff
CVS Commit Message (454 bytes, text/plain)
2008-03-03 13:36 EST, Nathan Kinder
no flags Details

  None (edit)
Description Nathan Kinder 2008-03-03 11:15:24 EST
Fractional replication is only currently allowed when the agreement destination
is a read-only replica.  We should allow fraction replication when the
destination is a master or a hub, with the caveat that the attributes replicated
for all agreements between masters are exactly the same.

This change is needed to support attributes that are dynamically generated by
each server instance, as is done when using the recently added memberOf plug-in.
Comment 1 Nathan Kinder 2008-03-03 11:31:52 EST
Created attachment 296630 [details]
Proposed Fix

This simply removes the check to see if we're trying to use a fractional
agreement  with a non-read-only replica when we acquire the replica.
Comment 2 Noriko Hosoi 2008-03-03 12:56:51 EST
Your change looks good to me.  It'd be nice if you could describe what happens
if 2 masters have different fractional replication config from each other: "No
problem" or "Error reported"?
Comment 3 Nathan Kinder 2008-03-03 13:28:48 EST
(In reply to comment #2)
> Your change looks good to me.  It'd be nice if you could describe what happens
> if 2 masters have different fractional replication config from each other: "No
> problem" or "Error reported"?

No error will be reported (at least not currently).  The problems that one would
encounter would be different results depending on which master you were taking
to.  This type of config could be done intentionally for some complex
deployment, but I think it's ideal to avoid this additional complexity due to
the confusion it could cause.
Comment 4 Nathan Kinder 2008-03-03 13:36:37 EST
Created attachment 296657 [details]
CVS Commit Message

Checked into HEAD and Directory_Server_8_0_Branch.  Thanks to Noriko for her
review!
Comment 7 errata-xmlrpc 2008-04-01 12:06:51 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0203.html

Note You need to log in before you can comment on or make changes to this bug.