Bug 435747 - backlight turning off on X exit; vbetool doesn't help
backlight turning off on X exit; vbetool doesn't help
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
9
All Linux
low Severity high
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-03 12:44 EST by Zack Cerza
Modified: 2009-07-14 13:34 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-14 13:34:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
log from this morning including reboot (41.91 KB, text/plain)
2008-03-04 10:14 EST, Zack Cerza
no flags Details
Xorg.0.log (20.21 KB, text/plain)
2008-03-04 13:12 EST, Ralf Ertzinger
no flags Details

  None (edit)
Description Zack Cerza 2008-03-03 12:44:25 EST
Description of problem:
When X exits (including rhgb), my backlight turns off. Just the backlight; the
display is still functional otherwise. vbetool won't turn it back on.
/sys/class/backlight is empty.

Workaround is rebooting :(


Version-Release number of selected component (if applicable):
xorg-x11-drv-i810-2.2.1-3.fc9.i386
kernel-2.6.25-0.82.rc3.git2.fc9.i686
Comment 1 Zack Cerza 2008-03-03 12:51:02 EST
Right, and my brightness keys don't work anymore.
Comment 2 Matěj Cepl 2008-03-03 18:54:22 EST
Zack, can I get /var/log/Xorg.0.log, please? Things are changing so fast in
Rawhide, that what we get in some other bug is probably outdated already.
Comment 3 Zack Cerza 2008-03-04 10:14:52 EST
Created attachment 296750 [details]
log from this morning including reboot
Comment 4 Ralf Ertzinger 2008-03-04 13:06:48 EST
Same for me. Don't know if it's related, but the brightness applet in gnome is
disabled (i.e. claims that the brightness can not be changed), and the
brightness keys on my X60s don't work, either.

Comment 5 Ralf Ertzinger 2008-03-04 13:12:52 EST
Created attachment 296775 [details]
Xorg.0.log
Comment 6 Zack Cerza 2008-03-04 13:41:38 EST
Try the following:

rmmod thinkpad_acpi
modprobe thinkpad_acpi brightness_mode=2
echo -n 7 > /sys/class/backlight/*/brightness

This allows me to turn my backlight on, but my brightness keys still don't work.
Comment 7 Zack Cerza 2008-03-04 13:43:27 EST
Note that with brightness_mode unset (I think the default is 3), I don't even
have a /sys/class/backlight/thinkpad_screen or a /proc/acpi/ibm/brightness.

Also, the brightness applet doesn't work either way.
Comment 8 Ulrich Drepper 2008-03-04 13:59:43 EST
(In reply to comment #6)
> Try the following:
> 
> rmmod thinkpad_acpi
> modprobe thinkpad_acpi brightness_mode=2
> echo -n 7 > /sys/class/backlight/*/brightness

I have no file in /sys/class/backlight/
Comment 9 Ralf Ertzinger 2008-03-04 14:21:15 EST
Neither do I.
Comment 10 Zack Cerza 2008-03-05 12:54:02 EST
Did you load thinkpad_acpi with brightness_mode=2? I need to do that to get the
file.
Comment 11 Zack Cerza 2008-03-05 13:01:27 EST
Well, in any case, it's starting to look like this is the kernel's fault.

Maybe I should file a separate bug for the hotkeys: Neither evtest nor lshal -m
notice when I press any of my Thinkpad's special keys.
Comment 12 Ulrich Drepper 2008-03-05 13:10:11 EST
(In reply to comment #10)
> Did you load thinkpad_acpi with brightness_mode=2? I need to do that to get the
> file.

Yes, I did.  No such file.
Comment 13 Zack Cerza 2008-03-05 13:23:15 EST
From thinkpad-acpi.txt:

"""
There are two interfaces to the firmware for direct brightness control,
EC and CMOS.  To select which one should be used, use the
brightness_mode module parameter: brightness_mode=1 selects EC mode,
brightness_mode=2 selects CMOS mode, brightness_mode=3 selects both EC
and CMOS.  The driver tries to autodetect which interface to use.
"""

I forget which is the default, but it should be easy to check. If the default is
3, try 1. If it's 1, try 3. Hopefully one of these will help...
Comment 14 Ulrich Drepper 2008-03-05 17:57:04 EST
(In reply to comment #13)
> I forget which is the default, but it should be easy to check. If the default is
> 3, try 1. If it's 1, try 3. Hopefully one of these will help...

I tried setting the mode to 1, 2 , and 3.  In neither case do I see a file or
directory in /sys/class/backlight.  And this is with a newer kernel:
2.6.25-0.90.rc3.git5.
Comment 15 Matthew Galgoci 2008-03-06 14:02:06 EST
I'm seeing the same as comment #14. My kernel ate my backlight :(
Comment 16 Ulrich Drepper 2008-03-28 23:55:10 EDT
Isn't it time to add this bug to the blocker list?  If this isn't fixed machines
in their default configuration (with graphical booting) will be unusable.
Comment 17 Ralf Ertzinger 2008-03-29 11:11:42 EDT
For me (X60s, intel driver) the backlight does no longer turn
off when X exits in current rawhide. The gnome applet still does not
work, but my brightness keys do.

In the other hand, while the backlight stays on, the console does
no longer display anything, but that's a different bug.
Comment 18 Ulrich Drepper 2008-03-29 23:02:09 EDT
Updated to kernel-2.6.25-0.172.rc7.git4.fc9.x86_64 and now it works.  As far as
I'm concerned, this bug can be closed.
Comment 19 James Gregory 2008-04-29 03:04:26 EDT
I'm seeing a similar problem in Fedora 9 Preview (rawhide), but only when the
laptop returns from suspend. The backlight on my Sony Vaio VGN-NR21J does not
light up, so I have to CTRL+ALT+F1 to the console and then back to X to make the
backlight return. I haven't seen this occur at any other point, only when
returning from suspend.
Comment 20 Zack Cerza 2008-04-30 13:31:55 EDT
So, now my backlight is is turning back on properly in all cases, but I still
don't have anything in /sys/class/backlight.
Comment 21 Bug Zapper 2008-05-14 01:44:47 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 22 Bug Zapper 2009-06-09 19:40:03 EDT
This message is a reminder that Fedora 9 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 9.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '9'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 9's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 9 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 23 Bug Zapper 2009-07-14 13:34:01 EDT
Fedora 9 changed to end-of-life (EOL) status on 2009-07-10. Fedora 9 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.