Bug 435753 - booty should require efibootmgr on ia64
booty should require efibootmgr on ia64
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: elilo (Show other bugs)
rawhide
ia64 Linux
high Severity high
: ---
: ---
Assigned To: Chris Lumens
Fedora Extras Quality Assurance
:
Depends On:
Blocks: fedora-ia64
  Show dependency treegraph
 
Reported: 2008-03-03 13:06 EST by Doug Chapman
Modified: 2008-03-04 10:18 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-04 10:18:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Doug Chapman 2008-03-03 13:06:56 EST
Description of problem:
A while back efibootmgr was removed from the elilo package into it's own
package.  It is no longer automatically there by default.  On ia64 booty uses
efibootmgr to set the boot options.  Without it anaconda hangs at "installing
bootloader".  We need to add the following to booty's specfile to make sure it
is available when needed:

%ifarch ia64
Requires: efibootmgr
%endif

Or, I hear rumors that some vendors may be building efi based x86 systems soon
also, so perhaps we don't want the %ifarch ia64.  Your call on that.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Doug Chapman 2008-03-03 13:17:44 EST
On second thought.....

efibootmgr is not available on ppc and probably won't be available on sparc,
alpha and arm.  Since booty is a noarch package we need to make sure that it
works on all platforms so %ifarch probably isn't valid since a booty.noarch
built on one platform will not be the same as on another.

I am thinking the right place for the "Requires efibootmgr" is in elilo.

thoughts?
Comment 2 Jeremy Katz 2008-03-03 13:39:33 EST
Yes, it should be in elilo.  Not booty.
Comment 3 Chris Lumens 2008-03-04 10:18:18 EST
This will be fixed in the next build of elilo.

Note You need to log in before you can comment on or make changes to this bug.