Bug 435764 - Corrupted double-linked list
Corrupted double-linked list
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: aprsd (Show other bugs)
8
All Linux
low Severity high
: ---
: ---
Assigned To: Lucian Langa
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-03 13:57 EST by eric@christensenplace.us
Modified: 2008-05-22 16:36 EDT (History)
1 user (show)

See Also:
Fixed In Version: 1.9.2-5.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-22 16:36:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description eric@christensenplace.us 2008-03-03 13:57:16 EST
Description of problem: APRSd will error out after only a few minutes of
running.  This failure generally occurs within one minute of it starting to run
and occurs faster under load.


Version-Release number of selected component (if applicable): 2.2.5-15.2.fc8

Additional info:
*** glibc detected *** aprsd: corrupted double-linked list: 0x09b20a80 ***
======= Backtrace: =========
/lib/libc.so.6[0x6c88e9]
/lib/libc.so.6(cfree+0x90)[0x6cc0f0]
/usr/lib/libstdc++.so.6(_ZdlPv+0x21)[0x20b36f1]
/usr/lib/libstdc++.so.6(_ZNSs4_Rep10_M_destroyERKSaIcE+0x1d)[0x209028d]
aprsd[0x805aaba]
aprsd[0x80618ca]
aprsd[0x806214c]
aprsd[0x80621b4]
aprsd[0x8070659]
/lib/libpthread.so.0[0x7f150b]
/lib/libc.so.6(clone+0x5e)[0x732b2e]
======= Memory map: ========
00110000-00111000 r-xp 00110000 00:00 0          [vdso]
00111000-0011b000 r-xp 00000000 08:02 49255      /lib/libnss_files-2.7.so
0011b000-0011c000 r-xp 00009000 08:02 49255      /lib/libnss_files-2.7.so
0011c000-0011d000 rwxp 0000a000 08:02 49255      /lib/libnss_files-2.7.so
0011d000-0011f000 r-xp 00000000 08:02 51509      /lib/libnss_mdns4_minimal.so.2
0011f000-00120000 rwxp 00001000 08:02 51509      /lib/libnss_mdns4_minimal.so.2
00120000-00124000 r-xp 00000000 08:02 49253      /lib/libnss_dns-2.7.so
00124000-00125000 r-xp 00003000 08:02 49253      /lib/libnss_dns-2.7.so
00125000-00126000 rwxp 00004000 08:02 49253      /lib/libnss_dns-2.7.so
0054b000-0055b000 r-xp 00000000 08:02 51582      /lib/libresolv-2.7.so
0055b000-0055c000 r-xp 00010000 08:02 51582      /lib/libresolv-2.7.so
0055c000-0055d000 rwxp 00011000 08:02 51582      /lib/libresolv-2.7.so
0055d000-0055f000 rwxp 0055d000 00:00 0 
00640000-0065b000 r-xp 00000000 08:02 51559      /lib/ld-2.7.so
0065b000-0065c000 r-xp 0001a000 08:02 51559      /lib/ld-2.7.so
0065c000-0065d000 rwxp 0001b000 08:02 51559      /lib/ld-2.7.so
0065f000-007b2000 r-xp 00000000 08:02 51560      /lib/libc-2.7.so
007b2000-007b4000 r-xp 00153000 08:02 51560      /lib/libc-2.7.so
007b4000-007b5000 rwxp 00155000 08:02 51560      /lib/libc-2.7.so
007b5000-007b8000 rwxp 007b5000 00:00 0 
007c1000-007e8000 r-xp 00000000 08:02 51563      /lib/libm-2.7.so
007e8000-007e9000 r-xp 00026000 08:02 51563      /lib/libm-2.7.so
007e9000-007ea000 rwxp 00027000 08:02 51563      /lib/libm-2.7.so
007ec000-00801000 r-xp 00000000 08:02 51565      /lib/libpthread-2.7.so
00801000-00802000 r-xp 00014000 08:02 51565      /lib/libpthread-2.7.so
00802000-00803000 rwxp 00015000 08:02 51565      /lib/libpthread-2.7.so
00803000-00805000 rwxp 00803000 00:00 0 
02000000-020e0000 r-xp 00000000 08:02 83407      /usr/lib/libstdc++.so.6.0.8
020e0000-020e4000 r-xp 000df000 08:02 83407      /usr/lib/libstdc++.so.6.0.8
020e4000-020e5000 rwxp 000e3000 08:02 83407      /usr/lib/libstdc++.so.6.0.8
020e5000-020eb000 rwxp 020e5000 00:00 0 
078dd000-078e6000 r-xp 00000000 08:02 51577      /lib/libcrypt-2.7.so
078e6000-078e7000 r-xp 00008000 08:02 51577      /lib/libcrypt-2.7.so
078e7000-078e8000 rwxp 00009000 08:02 51577      /lib/libcrypt-2.7.so
078e8000-0790f000 rwxp 078e8000 00:00 0 
07f43000-07f4e000 r-xp 00000000 08:02 51564      /lib/libgcc_s-4.1.2-20070925.so.1
07f4e000-07f4f000 rwxp 0000a000 08:02 51564      /lib/libgcc_s-4.1.2-20070925.so.1
08047000-0808a000 r-xp 00000000 08:02 92290      /usr/bin/aprsd
0808a000-0808b000 rw-p 00043000 08:02 92290      /usr/bin/aprsd
0808b000-0808e000 rw-p 0808b000 00:00 0 
09a45000-09b2c000 rw-p 09a45000 00:00 0 
ae4ff000-ae500000 ---p ae4ff000 00:00 0 
ae500000-aef9d000 rw-p ae500000 00:00 0 
aef9d000-af000000 ---p aef9d000 00:00 0 
af100000-af1b0000 rw-p af100000 00:00 0 
af1b0000-af200000 ---p af1b0000 00:00 0 
af2be000-af2bf000 rw-p af2be000 00:00 0 
af2bf000-af2c0000 ---p af2bf000 00:00 0 
af2c0000-afcc0000 rw-p af2c0000 00:00 0 
afcc0000-afcc1000 ---p afcc0000 00:00 0 
afcc1000-b06c1000 rw-p afcc1000 00:00 0 
b06c1000-b06c2000 ---p b06c1000 00:00 0 
b06c2000-b10c2000 rw-p b06c2000 00:00 0 
b10c2000-b10c3000 ---p b10c2000 00:00 0 
b10c3000-b1ac3000 rw-p b10c3000 00:00 0 
b1ac3000-b1ac4000 ---p b1ac3000 00:00 0 
b1ac4000-b24c4000 rw-p b1ac4000 00:00 0 
b24c4000-b24c5000 ---p b24c4000 00:00 0 
b24c5000-b2ec5000 rw-p b24c5000 00:00 0 
b2ec5000-b2ec6000 ---p b2ec5000 00:00 0 
b2ec6000-b38c6000 rw-p b2ec6000 00:00 0 
b38c6000-b38c7000 ---p b38c6000 00:00 0 
b38c7000-b42c7000 rw-p b38c7000 00:00 0 
b42c7000-b42c8000 ---p b42c7000 00:00 0 
b42c8000-b4cc8000 rw-p b42c8000 00:00 0 
b4cc8000-b4cc9000 ---p b4cc8000 00:00 0 
b4cc9000-b56c9000 rw-p b4cc9000 00:00 0 
b56c9000-b56ca000 ---p b56c9000 00:00 0 
b56ca000-b60ca000 rw-p b56ca000 00:00 0 
b60ca000-b60cb000 ---p b60ca000 00:00 0 
b60cb000-b6acb000 rw-p b60cb000 00:00 0 
b6acb000-b6acc000 ---p b6acb000 00:00 0 
b6acc000-b74cc000 rw-p b6acc000 00:00 0 
b74cc000-b74cd000 ---p b74cc000 00:00 0 
b74cd000-b7f33000 rw-p b74cd000 00:00 0 
bffe2000-bfff7000 rw-p bffea000 00:00 0          [stack]
Aborted
Comment 1 Lucian Langa 2008-03-09 05:34:36 EDT
Seems I cannot reproduce this.
Please suggest a specific conf file that might help if any.
Please also tell me if there are specific actions you performed.
There's also a new package that implements log directory support and log rotation,
please try that.
http://koji.fedoraproject.org/koji/buildinfo?buildID=42173

Comment 2 Fedora Update System 2008-03-09 10:50:20 EDT
xastir-1.9.2-5.fc8 has been submitted as an update for Fedora 8
Comment 3 Fedora Update System 2008-03-13 03:48:51 EDT
xastir-1.9.2-5.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update xastir'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F8/FEDORA-2008-2470
Comment 4 eric@christensenplace.us 2008-03-13 09:35:39 EDT
(In reply to comment #2)
> xastir-1.9.2-5.fc8 has been submitted as an update for Fedora 8

I think this was posted to the wrong ticket.  This ticket is for APRSd not Xastir.
Comment 5 eric@christensenplace.us 2008-04-03 14:42:26 EDT
Got it installed and functioning.  All okay so far.  As soon as I get home I'll
put it under load and see what happens. 
Comment 6 eric@christensenplace.us 2008-04-03 22:18:17 EDT
I put aprsd under load tonight and had it running in excess of 7 hours with no
problems.
Comment 7 eric@christensenplace.us 2008-04-03 22:19:01 EDT
I don't think the latest version is in the Fedora repos.
Comment 8 Lucian Langa 2008-04-04 00:44:29 EDT
Eric,
aprsd package has been submitted with bodhi.

https://admin.fedoraproject.org/updates/F8/FEDORA-2008-2411

at this moment package has been pushed for testing.
Depending on the karma it gets (>2) can be pushed to stable.
Please go there and post your negative or positive feedback.

Thanks
Comment 9 eric@christensenplace.us 2008-04-04 06:40:28 EDT
Done.
Comment 10 Fedora Update System 2008-05-22 16:36:39 EDT
xastir-1.9.2-5.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.