Bug 435790 - HD Realtek soundcard is wronlgy detected as HD Intel
HD Realtek soundcard is wronlgy detected as HD Intel
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: pciutils (Show other bugs)
8
i686 Linux
low Severity high
: ---
: ---
Assigned To: Martin Stransky
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-03 16:54 EST by Ionut Radu
Modified: 2008-03-04 14:08 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-04 14:08:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
scsconfig.log. Couldn't attach scsrun.log (47.75 KB, application/octet-stream)
2008-03-03 16:54 EST, Ionut Radu
no flags Details
scsrun.log (3.00 KB, application/octet-stream)
2008-03-03 16:56 EST, Ionut Radu
no flags Details

  None (edit)
Description Ionut Radu 2008-03-03 16:54:53 EST
Description of problem:
system-config-soundcard detects an Acer Aspire 5315-2442 laptop soundcard as
being HD Intel when it is in fact HD Realtek. This results in no sound.

Version-Release number of selected component (if applicable):
2.0.6-11.fc8

How reproducible:
Just run system-config-soundcard on an Acer Aspire 5315-2442 laptop

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Ionut Radu 2008-03-03 16:54:53 EST
Created attachment 296681 [details]
scsconfig.log. Couldn't attach scsrun.log
Comment 2 Ionut Radu 2008-03-03 16:56:16 EST
Created attachment 296682 [details]
scsrun.log
Comment 3 Ionut Radu 2008-03-04 05:46:14 EST
Actually I think the problem is in the pci-utils not in the system-config-soundcard.
Windows is successfully using the Realtek audio driver from acer site :
http://support.acer-euro.com/drivers/notebook/as_5315.html
Note : this driver is the only audio driver available for my laptop on producer
site.
Comment 4 Martin Stransky 2008-03-04 05:55:40 EST
system-config-soundcard detects nothing, it juts reads data from kernel. HD
Realtek means HD audio standard and it was designed by intel so the driver for
this sound device is called HD Intel and works for all HD chips.

Anyway, your sound card seems to be detected properly. The log looks sane. I can
be some kernel misconfiguration. 

See this page:

http://www.mjmwired.net/kernel/Documentation/sound/alsa/ALSA-Configuration.txt

you may modify this line from /etc/modprobe.conf with:

options snd-hda-intel index=0 model=acer
Comment 5 Ionut Radu 2008-03-04 14:01:02 EST
After added model=acer to the "options snd-hda-intel index=0", sound suddenly
became functional. 

thanks.

Note You need to log in before you can comment on or make changes to this bug.