Bug 435878 - Installer enumerates drives strangely on a three drive system producing an unbootable system
Installer enumerates drives strangely on a three drive system producing an un...
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
8
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-04 03:42 EST by Jyrki Tikka
Modified: 2008-05-18 18:00 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-04 08:14:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jyrki Tikka 2008-03-04 03:42:28 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.12) Gecko/20080201 Firefox/2.0.0.12

Description of problem:
A three drive system
- the boot drive attached to the motherboard PATA controller
- other two drives attached to a Promise Ultra100/133TX2 two channel PCI card
- drives used to be called hda, hde and hdg
- on a working system these drives are now sda (boot), sdb and sdc

The installer calls the boot disk hd2/sdc and proceeds to install normally. When rebooting the system after installation, GRUB cannot find the boot partition on disk hd2 because it will see the boot disk as hd0

Version-Release number of selected component (if applicable):
Fedora 8

How reproducible:
Always


Steps to Reproduce:
1. Install system with additional disks connected to a PCI PATA controller
2. Reboot after installation


Actual Results:
GRUB unable to boot the system

Expected Results:
GRUB should be able to boot

Additional info:
This problem can be solved by the following steps
- after installation boot with the rescue disk
- chroot /mnt/sysimage
- edit /boot/grub/grub.conf replacing references to hd2 width hd0
- reboot
Comment 1 Jeremy Katz 2008-03-04 08:14:43 EST
Unfortunately, PC hardware doesn't really give a reliable way of mapping from
BIOS drives to any other way of knowing the drives.  We use what's there, but a
lot of hardware still doesn't support it.

This is why on the primary partitioning screen, we now ask the question "where
do you want to install the bootloader" and we then take the guess that that is
the first bios drive.  Also, I've reworked the main bootloader screen so that
things are clearer as to what your drive order is and make that clearer.
Comment 2 Jyrki Tikka 2008-05-18 18:00:01 EDT
In Fedora 9 hardware probing and detection is based on HAL and udev. This causes
anaconda to have the same view of the disks as the normal installed system. This
simply means that as of Fedora 9 the problem seems to be solved.

Note You need to log in before you can comment on or make changes to this bug.