Bug 435911 - ppc64 boot images not being built for rawhide
ppc64 boot images not being built for rawhide
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: David Cantrell
Fedora Extras Quality Assurance
:
Depends On: 436181
Blocks: F9Beta
  Show dependency treegraph
 
Reported: 2008-03-04 08:06 EST by James Laska
Modified: 2013-09-02 02:24 EDT (History)
4 users (show)

See Also:
Fixed In Version: anaconda-11.4.0.47-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-10 10:46:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description James Laska 2008-03-04 08:06:58 EST
Description of problem:

ppc64 boot images (kernel+initrd) missing from rawhide-20080303.  jkeating
indicated that an error in the compose log pointed to the new yumdownloader
changes in scripts/mk-images.

Version-Release number of selected component (if applicable):

rawhide-20080303 (anaconda-11.4.0.42-1)

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:
/mnt/rawhide/rawhide-20080303/ppc/os/ppc/chrp
/mnt/rawhide/rawhide-20080303/ppc/os/ppc/mac
/mnt/rawhide/rawhide-20080303/ppc/os/ppc/ppc32

Expected results:
/mnt/rawhide/rawhide-20080303/ppc/os/ppc/chrp
/mnt/rawhide/rawhide-20080303/ppc/os/ppc/mac
/mnt/rawhide/rawhide-20080303/ppc/os/ppc/ppc32
/mnt/rawhide/rawhide-20080303/ppc/os/ppc/ppc64

Additional info:

Mar 03 11:52:38<@   jkeating> | jeremy: there is a ppc64 kernel in the tree, but
buildinstall isn't finding it
Mar 03 11:52:52<@   jkeating> | yumdownloader is throwing usage errors, which I
wouldn't think it would do that if the package just couldn't be found
Mar 03 11:53:54<@      dwmw2> | we have no iseries kernel any more.
Mar 03 11:53:59<@      dwmw2> | the generic ppc64 kernel should run on iSeries
Mar 03 11:54:43<      jeremy> | dwmw2: yes, but some of the anaconda
infrastructure to support a separate one is still there.  it just becomes a noop
Mar 03 11:54:51<@      dwmw2> | yep
Mar 03 11:55:19<@      dwmw2> | I was tempted to remove it recently but don't 
Mar 03 11:56:18<      jeremy> | jkeating: the usage error basically means that
repoquery isn't finding anything (I'll make it give something a little nicer as
an error :-)
Mar 03 11:57:09<      jeremy> | jkeating: (ie, repoquery kernel.ppc64 isn't
returning anything)
Comment 1 Jeremy Katz 2008-03-04 08:32:36 EST
I tried to add some bits so the error would be more clear in anaconda, but we'll
need a new buildinstall run to see.  And I think that the new yum flubbed up
today's trees
Comment 2 Jesse Keating 2008-03-06 09:31:47 EST
This was due to anaconda changes to use repoquery and yumdownloader to get
packages.  Since the ppc tree is composed in a ppc environment, we need to pass
--archlist to repoquery in order to find .ppc64 packages.  Unfortunately
yumdownloader doesn't have an option like this, so even when we find ppc64
packages via repoquery we can't download them with yumdownloader.  I've
submitted a patch to yumdownloader to add an --archlist option so that we can
download things from a non-compat arch.  Blocking this bug with that bug.  After
that's accepted, we'll need one more change to anaconda to make use of the option.
Comment 3 James Laska 2008-03-10 10:45:23 EDT
Rawhide of 20080310 now contains:
 * ppc/ppc64/{vmlinuz,ramdisk.image.gz}
 * images/netboot/ppc64.img

http://download.fedora.redhat.com/pub/fedora/linux/development/ppc/os/ppc/ppc64/

Note You need to log in before you can comment on or make changes to this bug.